Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
KDS 3.1.0/KSDK 2.0/Multilink Universal Issue
Alex U. Feb 23, 2016 at 11:26 AM (11:26 hours)
Staff: Gerardo R.

  • I have KDS 3.1.0 running on Win7.

    If I create a project that uses the KSDK 1.3.0 library, I can download & debug it on my K24 based target using a Multilink Universal (Rev B). I can also create/debug projects for my FRDM-K64 board.

    However, if I create a new project with the KSDK 2.0 library, when I try to debug it the gdbserver process locks up. The status dialog first says "Launching: Initializing debugger services" for a few seconds then says "Launching: Configuring GDB Aborting configuring GDB". At that point I have to exit KDS and manually kill "pegdbserver_console.exe*32" using the task manager.

    Upgrading to "GNU ARM PEMicro Interface Debugging Support" does not solve the problem.

    If I change the FRDM board to use the J-Link interface then the problem goes away. Is there a newer version available for the pegdbserver?



  • There is no newer version, that was released just two days ago. Can you provide any logs or screenshots to help me understand the issue?

  • When I run Eclipse, I get the following session log:

    !SESSION 2016-02-24 08:21:13.584 -----------------------------------------------
    java.vendor=Oracle Corporation
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
    Framework arguments: -product com.somniumtech.branding.kds.ide -showlocation
    Command-line arguments: -os win32 -ws win32 -arch x86 -product com.somniumtech.branding.kds.ide -showlocation

    !ENTRY org.eclipse.egit.ui 2 0 2016-02-24 08:21:16.722
    !MESSAGE Warning: EGit couldn't detect the installation path "gitPrefix" of native Git. Hence EGit can't respect system level
    Git settings which might be configured in ${gitPrefix}/etc/gitconfig under the native Git installation directory.
    The most important of these settings is core.autocrlf. Git for Windows by default sets this parameter to true in
    this system level configuration. The Git installation location can be configured on the
    Team > Git > Configuration preference page's 'System Settings' tab.
    This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

    !ENTRY org.eclipse.egit.ui 2 0 2016-02-24 08:21:16.722
    !MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
    user global configuration and to define the default location to store repositories: 'C:\Users\Alex'. If this is
    not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
    EGit might behave differently since they see different configuration options.
    This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

    !ENTRY com.processorexpert.core.ide.wizard.ui 2 0 2016-02-24 08:21:17.377
    !MESSAGE External elements location C:\Freescale\KDS_3.0.0\eclipse\ProcessorExpert\BoardConfigurations/wizard_data does not exist

    The above entries are written when Eclipse starts.

    The following is written when I kill pegdbserver using the Task Manager.

    !ENTRY org.eclipse.cdt.dsf 4 -1 2016-02-24 08:23:40.570
    !MESSAGE Uncaught exception in DSF executor thread
    !STACK 0
    java.lang.IllegalStateException: The service has been unregistered
       at org.eclipse.osgi.internal.serviceregistry.ServiceRegistrationImpl.unregister(
       at org.eclipse.cdt.dsf.service.AbstractDsfService.unregister(
       at org.eclipse.cdt.dsf.gdb.service.GDBMemory_7_6.shutdown(
       at org.eclipse.cdt.dsf.gdb.launching.ShutdownSequence$ServiceShutdownStep.execute(
       at org.eclipse.cdt.dsf.concurrent.Sequence.executeStep(
       at org.eclipse.cdt.dsf.concurrent.Sequence.access$2(
       at org.eclipse.cdt.dsf.concurrent.Sequence$2.handleSuccess(
       at org.eclipse.cdt.dsf.concurrent.RequestMonitor.handleCompleted(
       at org.eclipse.cdt.dsf.concurrent.RequestMonitor$
       at java.util.concurrent.Executors$ Source)
       at Source)
       at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
       at java.util.concurrent.ScheduledThreadPoolExecutor$ Source)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
       at java.util.concurrent.ThreadPoolExecutor$ Source)
       at Source)

    !ENTRY 2 2 2016-02-24 08:23:40.960
    !MESSAGE Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.debug.internal.ui.DebugUIPlugin$8

    In addition, the following is written to the Console when I attempt to debug the project.

    GNU gdb (GNU Tools for ARM Embedded Processors)
    Copyright (C) 2013 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <>;
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law. Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "--host=i686-w64-mingw32 --target=arm-none-eabi".
    For bug reporting instructions, please see:

    I have a screenshot of the "Launching" dialog box displaying the error, but I don't see how to attach it.

  • OK, I've found the source of the error for you.

    When the Kinetis SDK 2.x Project Wizard creates a new project, it generates a launch configuration file which contains the following entry:

    <stringAttribute key="com.pemicro.debug.gdbjtag.pne.gdbClientOtherCommands" value="set mem inaccessible-by-default off&amp;#13;&amp;#10;set tcp auto-retry on&amp;#13;&amp;#10;set tcp connect-timeout 30"/>

    However, the value field should be:

    <stringAttribute key="com.pemicro.debug.gdbjtag.pne.gdbClientOtherCommands" value="set mem inaccessible-by-default off&#13;&#10;set tcp auto-retry on&#13;&#10;set tcp connect-timeout 30"/>

    If you compare the two strings, you'll see that the wizard has taken the '&' of the numeric character reference and re-encoded it as a character entity reference. Eclipse decodes the character entity when it reads in the configuration file, but the result is the numeric character reference is not decoded. When the command string containing these numeric references is passed to your gdbserver, it crashes.

    So there are two bugs at play here:
    1. The KSDK Project Wizard is generating launch files with invalid strings.
    2. Your gdbserver doesn't handle unexpected input gracefully.

  • Thanks a lot for tracking this down for us. I'll create a bug report for this on our end and make sure the project wizard issues make their way back to NXP.

    • I am using KDS 3.2.0 on WIN10 with MKE04Z1284.h (wizard "Kinetis SDK 1.x Project") and I have the same problem with blocking "Launching: Configuring GDB Aborting configuring GDB" while flashing the chip.

      I have to kill the Task "arm-none-eabi-gdb.exe". After that flashing is successfull.

      But this is only with NEW projects, older projects (3..4 weeks old) are working fine. I couldn't find any notable difference with ExamDiff.

      I haved checked the entry in launch configuration. It is OK and there is no difference to the older projects.

      • This looks like an unrelated issue if the configurations are identical. If you were to create the exact same project now (i.e. debug the same target with the same settings), would you see a failure? Have you tried updating all of your plugins to the latest version?

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement