Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
USB-ML-Universal rev C(Blue) not working but old "Green"" working
Qi T. Feb 5, 2016 at 03:26 AM (03:26 hours)
Staff: Takao Y.

  • We bought 4 USB-ML-Universal rev C from digikey and installed the latest driver. None of them works with IAR. However, all old USB-ML(Green without Universal) works well either with old driver or new driver. PC can link to the unit but the unit cannot link to target. Blue and Yellow all on and we use Win 7. Need help!!!

    Qi




    Comments

  • Greetings,

    What chip architecture are you trying to get supported? Have you downloaded the CD that came with the multilink? Did you use the firmware updater utility to change the firmware to support your chip?


    Takao Yamada

    • K60 and STM32, I download from CD and web both. how to update firmware utilit to support chips? Thanks,

      Qi

    • Solved! Thanks!

      Qi

      • Hi I'm try to use the Multilink Rev C with STM32 and I cannot program the correct firmware into it (there is only freescale micros available).
        How did you solved it ?
        Thanks
        SDS

        • Greetings,

          Please select Kinetis in the updater utility. Although it is named after a Freescale name, the firmware is still the same to support the STM32 devices.


          Takao Yamada

          • Thanks so much: it works !!!
            But I've another 'little' problem.
            I'm using Keil environment and ST32

            The 'script' (erase/program) runs twice in the same way.
            Here what happens (unfortunately ther isn't possibility to add a screen shot image...):

            CPROGACMP Programmer for Freescale - Version 5.89.00.00 - [Status Window]

            Copyright 2012 P&E....
            Command Line :"C:\Keil_v5\\UV4\UV4.exe"
            CMD>CM C:\Keil_v5\ARM\PEMicro\P&E\supportFiles_ARM\ST\STM32L0\ST_STM32L073VZ_1x32x48k.arp
            Initializing. Initialized.
            ;version 1.00, 03/31/2016, Copiright 2016 P&E....
            ;device ST, STM32L073VZ, 1x32x48k
            ;begin_cs device=$08000000, length=$00030000, ram=$20000000
            Loading programming algoritm ... Done
            CMD>EM
            Erasing. Module has been erased.
            CMD>PM
            Programming Address $08xxxx (repeating up to programmed all code)

            Then there is some other message (too fast to be read...), but something like "everything ok"

            After that the SAME is repeated again and at the end I can debug my application.

            Can you help me, please ?
            Thanks in advance
            SDS

            • Greetings,

              This should be its own forum thread as it is not related to the original topic. Please create a new thread and I will have our Keil expert look into this.


              Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement