Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Bricked FRDM-KE06Z after update to BOOTUPDATEAPP_Pemicro_v111.SDA
. Jan 17, 2016 at 10:31 PM (22:31 hours)
Staff: Zahar R.

  • Hi,
    I put the board into bootloader mode, and put the BOOTUPDATEAPP_Pemicro_v111.SDA on the usb drive, then after a bit (20s?) unpowered & powered the board.

    While I can't recollect exactly what it did at the time of flashing, instead of coming back up, the LED started blinking quickly at about 10hz for 1s, then went off for a second, then blinked at 10hz for 1s again, then repeats.

    After 10min or so I unplugged the board and replugged it. It did the same thing - flashes quickly at about 10hz for 1s, stops for a second, then again at 10hz, then repeats. Trying to put it into bootloader by holding reset has no effect.

    It also does not enumerate via USB at all. Nothing in 'lsusb' or 'dmesg' about the device being plugged in. No ttyACM0, no usb drive shows up, etc.

    Very strangely, it did come back to life for a brief moment and enumerated via USB. The bootloader showed 1.11, and the app version was 0. I figured it was a bad flash so I put the bootloader update on it again, and it went back to doing the same 10hz blinking thing.

    It came back to life a second time (I have no idea why, it is random), and I tried putting MSD-DEBUG-FRDM-KE06Z_Pemicro_v118.SDA on it. After powering off and back on, the LED did not even turn on. It did not show up via USB either.

    I was still able to get into bootloader after this happened, so I tried putting the original MSD-DEBUG-FRDM-KE06Z_Pemicro_v114.SDA back on it.

    Now it just does that 10hz blinking pattern again.

    Is there any way of bringing it back to life? I put a jtag on the k20 chip, and I could only get it to show up by holding RST low. But I was not able to read any memory locations etc. openocd said:

    > reset
    JTAG tap: k20.cpu tap/device found: 0x4ba00477 (mfg: 0x23b, part: 0xba00, ver: 0x4)
    **** ****
    **** Your Kinetis MCU is in secured state, which means that, ****
    **** with exception for very basic communication, JTAG/SWD ****
    **** interface will NOT work. In order to restore its ****
    **** functionality please issue 'kinetis mdm mass_erase' ****
    **** command, power cycle the MCU and restart OpenOCD. ****
    **** ****

    Is there any hope in bringing this back to life? Will I need to send it in?



    • Hi Matt, 

      What operating system are you currently working under? Do you have an active anti-virus program running on your PC?

      What might be confusing is that in order for Bootloader update to happen, one has to drop in a Bootloader update application, which effectively replaces a resident DEBUG/MSD application.

      Following a Bootloader update, one has to start the board in Bootloader mode and drag and drop a native FRDM or TWR board OpenSDA app into it. In this case, you would be updating the board with MSD-DEBUG-FRDM-KE06Z_Pemicro_v118.SDA application.

      Can you try to see if the board enumerates in Bootloader mode on any other PC? Below is a sequence of steps one would follow to properly update Bootloader on a given OpenSDA board:

      To update Bootloader please follow these steps:

      1. Enter bootloader mode (generally by holding down the target reset button on the OpenSDA board and plugging in the USB connection).

      2. Drag and drop the BOOTUPDATEAPP.SDA file to the root directory of the Bootloader "drive".

      3. Unplug and replug your OpenSDA board to initiate Bootloader update. Bootloader update should take less than 15 seconds (probably averages 3 seconds).

      4. Once update is complete, OpenSDA will automatically enumerate in Bootloader mode and green status LED will go on blinking with .5 second on/off intervals.

      5. Run the SDA_INFO.HTM file in the root directory of the Bootloader "drive".

      6. Following a Bootloader update, one should boot up the board in Bootloader mode and drag and drop corresponding FRDM or TWR OpenSDA firmware in order to replace resident Bootloader Update application.

      7. After this OpenSDA firmware update, the board will be ready for use as DEBUG interface or MSD (mass storage device) following unplugging and replugging the board into a USB port.

      Best Regards,

      • Hi Zahar,
        I am running Linux. No antivirus.

        The problem is, the board will not enter bootloader mode anymore after the failed bootloader update.

        If I power on the board while holding the reset button, it still does not show up via USB *at all*, and it just blinks quickly doing the 10hz pattern.

        So I cannot enter bootloader mode (or regular mode, either) to try the update again.

        This is all it is doing, whether I hold reset down when powering on or otherwise. It just blinks:

        It does not show up in lsusb output either:
        matt@box:~$ lsusb|grep '2504:0200'


      • Also, to answer your question: I tried another PC, it still does not enter bootloader or enumerate via USB.


  • Hi Matt, 

    Just to clarify, the K20 device that stores the OpenSDA firmware is secured and one cannot re-flash the whole OpenSDA image without sending the unit back to P&E. We would be happy to re-flash this board for you.

    When you said that you were trying to put the Bootloader application and then MSD-DEBUG firmware application onto the board, were you doing so while keeping the board in Bootloader mode?

    It looks like your board is stuck in a bad state which could be caused by either an issue with actual enumeration (linux usb drivers) or the fact that the firmware/bootloader got corrupted during upgrade. Do you have access to a Windows PC to do a quick smoke test?

    Best Regards,

  • Hi,
    Yes I installed both updates while in bootloader mode. The board has been non-functional since I initially tried the 1.11 bootloader update.

    I only have Windows in a VM, but I cannot passthru the USB device to the VM because it is not even detected on my system.


  • Hi, 

    I am in a similar position but with the FDRM-KL25Z. First use out of the box booted into bootloader mode and saw (in SDA_INFO) that it was v1.09 so wanted to have the latest for best experience.

    Did the upgrade procedure as advertised above (though I am using OSX). Dropped "BOOTUPDATEAPP_Pemicro_v111.SDA" in the root folder, waited 15 seconds, cycled the power, waited 15 seconds but no enumeration. I get the 8-flashes cycle as mentioned in the manual so this is in some error mode. I looked at the content of LASTSTAT (which I failed to look in when taking it out of the box) and it says "Programming..."

    So it's evident that I can still get into bootloader, but nothing more. It will not accept any other file because it's left in this state.

    Do I have a bricked device? Do you have any advice for me?

    Thank you.


  • fixed.  Apparently OSX not compatible with this version and the Win7 VM I was using was unable to do the job either.  My Win10 PC also failed to update it. Had to find a dedicated Win7 machine to get the job done.

  • Hi Matt, 

    It would be great if you can try to boot up this board under a native Windows 7 or XP IDE to confirm it is dead. If you are willing to ship it to P&E, we will be happy to re-flash it for you at no charge, as long as you are willing to cover the shipping.

    Please let me know if this is something you are interested in pursuing.

    Best Regards,

  • So, I finally fixed the board that was bricked in 2015 due to the proprietary locked bootloader destroying itself during a "routine" bootloader upgrade.

    It required SMD rework (of a 32QFN - which I'm not personally capable of) to replace the MK20DX128VFM5 with a factory fresh one without any security bits set. Once that was in place, I was able to flash a bootloader intended for another similar-enough FRDM board: FRDM-K28F, which has a very similar OpenSDA implementation with regard to pinout to the FRDM-KE06Z. The filename used was OpenSDA-2.2-Bootloader-K20DX.bin and was flashed via JTAG to the MK20DX128VFM5 to 0x0.

    I wasn't able to get the newer CMSIS-DAP program compiling for the KE06Z4 - the FlashAlgo project dependency doesn't support the FTMRE flash controller on the KE06Z. But I did find that Segger 07_OpenSDA_FRDM-KE06Z.bin firmware was unencrypted and/or uncompressed and worked immediately after doing a drag-and-drop flash via the FRDM-K28F bootloader.

    I've so far tested the basics like dumping flash, reprogramming flash, reading registers, and reset/halt. All is working well.


  • Er, sorry - bricked in January of *2016* I mean :)

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement