Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Freescale MC9S12DP512: Erase Failure at 0x8000
John A. Jan 8, 2016 at 06:31 PM (18:31 hours)
Staff: Takao Y.

  • Our firmware update procedure has stopped working. It's worked for years, but now we're getting an error. I'm hoping someone here can give us some ideas on how to troubleshoot the problem.  Here's what is happening and what we've tried so far.

    We're using a P&E USB Multilink Interface to program Freescale MC9S12DP512 MCU's. We use prog12z, and the mcu erases, programs, and verifies. But when we go to our in-house app and write to the flash of the MCU, we get an error: "Write failure at address 0x8000. We're seeing this on 2 different computers, on 2 different P&E Interfaces (one's Rev C, one's Rev B), 4 different MCU's, even 2 different USB cables. The computers are running Windows 7. This has been working since 2005, but has stopped working. Any one have suggestions on how we can determine what's wrong?

    Thanks,




    Comments

  • Greetings,

    Are there any changes you have made recently that may clue you into what may have caused this issue?

    Since you are able to flash program using PROG12Z, we know that you are able to talk to the chip and the multilinks, drivers, and software are in working condition.

    So my question is what is being used in your in-house app to communicate? Are you using UNIT12Z?


    Takao Yamada

    • The biggest change is that we've moved to Windows 7 (however, we're also experiencing this on a machine that still has XP). We’re looking at reinstalling drivers, etc, however the process continues to work for our current generation products. The problem arises now because we have need to modify an older generation product, and that's where it's failing.

      We're not using UNIT12Z, but are doing our own low level RS-232 IO code.

  • Greetings,

    I am not sure how much I can help you. The P&E hardware and software seems to be in working condition. Those has not changed and continues to work on current gen products.

    Does the software and hardware work for older generations? If so, there is not much we can do for you if you are using your own RS232 in-house app. Maybe try disconnecting the P&E hardware while using the RS232. Maybe the multilink is holding the chip is a state that does not allow flash programming from other sources.


    Takao Yamada

  • Hi Takao, 

    Thanks for your response. Where can I learn more about the multilink holding the chip in such as state? We're unplugging the multilink after programming, and the error happens when we attach to our board from our custom software.

    Also, I suppose a next step would be to log a support request with you. I see entries for PO's and such. Could you have someone contact me (either here, or email, or phone) and explain your fee structures?

    Thanks,

    John

  • Greetings,

    We do not have a fee structure.

    You could log a support request by going to our Support page -> support requests and create a ticket. However note that we do not support customers who are doing their own flash programming tools or custom software. We will support up to working on tools like using the multilink and the PROG12Z software. Outside of that, you are on your own.

    When you create the ticket, attach the S19/PHY/ELF file you are using to program the chip. We can look at your binary file and find out why writing to address 0x8000 is giving you problems. For example, if you are already writing to this location, then you will have errors. That is the nature of flash.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement