Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Bootloader mode update error MCF51CN
Pawel N. Dec 5, 2015 at 10:59 AM (10:59 hours)
Staff: Takao Y.

  • Hello,
    I have TWR-MCF51CN board and I'd like to update it by P&E firmware updater. I connect my board by Mini USB , it's detected by during the update I have to set jumper on J16 to activate bootloader mode. When I reconnect my board with jumper on my computer can't detect device and P&E updater also.
    Please help me with this problem.
    Greetings,
    Pawel




    Comments

  • Greetings,

    The firmware on your TWR for MCF51CN is called OSBDM. To firmware update, you should be downloading the software and utilities from this website:
    http://www.pemicro.com/osbdm/

    You are correct to activate the bootloader by moving the jumper, though the specific jumper will depend on revision of the board. But you will know it is in bootloader mode when you connect the board again and the P&E driver indicates that your board is running bootloader. This can be seen in device manager. If the computer cannot detect the bootloader or your board from the device manager, then you need to look into reinstalling the drivers:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=53


    Takao Yamada

  • I tried reinstall my drivers but it didn't help. In device manager board is undetected with jumper on and I can't check if it is in bootloader mode. Without jumper device manager sees it.
    In jungo is installed PEMicro USB Serial Port (i1) (v.12.2.0.0) and in LibUSB-Win32 devices is installed Open Source BDM - Debug Port (v.1.2.3.0).

  • Greetings,

    Could you try something for me. Could you try on a different computer? I have seen this problem myself where I am the only person at the company who has problems seeing the bootloader firmware. I have to switch to a different computer to get it working. It is a very rare and unusual problem. Somehow the problem disappeared without reason.

    If you can get it working on a different computer, then you have the corner case I am talking about. If you cannot get it working on any computer, then we can look into other debugging methods.


    Takao Yamada

  • I tried on another computer and I think that I'm that unlucky example who has problem with his own computer. On the other PC it's updated without any problems. I have one more question. I sometimes use older version of CodeWarrior which in incompatible with the drivers which I updated. Is it possible to downgrade version of the driver on board when I will need it? I try to reinstall driver in device manager and it insall the newest version again.
    Thanks for your help.

  • Greetings,

    At least you were able to get the bootloader firmware recognized.

    I highly suggest not downgrading the firmware. Yes there could be incompatibility issues, but latest versions do have bug fixes and features that can only be found with latest. What older version of Codewarrior are you using, and why are you in need of separate versions? You know you can import older projects into newer versions.


    Takao Yamada

  • I'm using CodeWarrior Devolopments Studio for Microcontrollers v. 6.3. I'm using it most of the time and I know it better than CodeWarrior 10.6 but I think I get quick start with newer CodeWarrior and it will be no problem. If older versions of project will work without errors it will be great.
    Thanks for help.
    Best regards.

  • Greetings,

    Within CW10.6, Go to File Menu -> Import... -> Codewarrior -> Codewarrior Classic Project. Here you will select the .MCP file that is correlated to your CW6.3 project and it should attempt to import the project into the new environment. Note, that this only imports the code and paths but not debug settings and other unique configurations you may have had.

    If you want CW6.3 to work with the latest firmware, here is the patch to update your Codewarrior with the latest files. This should allow you to switch between IDE's with no problems:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement