Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
cyclone_launch error
Bill B. Nov 19, 2015 at 09:35 AM (09:35 hours)
Staff: Johnny N.

  • We're running a batch file which starts "cyclone_launch" on a Windows 7, 64bit system and intermittently getting an error message.   This same script worked fine when we previously ran it on a Windows XP Service Pack 3 system.  The error message popup is "Cyclone_launch.exe has stopped working.  A problem caused the program to stop working correctly.  Windows will close the program and notify you if a solution is available".  Any suggestions on what could be causing this?  We're using Cyclone Automated Control Package V1.2.




    Comments

    • I should also add that we're using a Cyclone Max connected via USB IP running firmware version V7.84-6.2.  The chip we're programming is a Freescale MPC5554.

      • Hi,

        Can you paste the contents of your batch file?

        -Johnny

  • Hi.  Thanks for your response...

    The batch file contents are:

    @echo off
    del T1821LOG.txt
    del T1821PROG_Screen_Out.txt
    CYCLONE_LAUNCH T1821PROG.CFG -O T1821PROG_Screen_Out.txt
    if errorlevel 1 goto fail
    :PASS
    echo PASS! > T1821LOG.txt
    echo PASS!
    goto done
    :fail
    echo FAIL! > T1821LOG.txt
    echo FAIL!
    goto done
    :done
    exit


    Contents of T1821PROG.CFG:

    OPENTYPE=IP
    PORT=USB
    CYCLONE=209.61.110.66
    SETTIMEOUT=20
    ;Use image #1 = Level 21 image
    ;Use image #2 = Level 23 image
    ;Use image #3 = Level 24 image
    ;Use image #4 = Level 25 image
    IMAGENUM=2
    ;CHANGE IMAGENUM TO CORRESPONDING IMAGE
    ;OPERATION COMMANDS
    START

    • Hi,

      The version you're running is very old and dates from 2010 or even earlier. We haven't received any reports of similar issues from other users so I think you should try updating to the latest version of the Cyclone_Launch application. I'll send you a download link in a few minutes.

      Regards,
      Johnny
      P&E

  • I will give it a try.

    Regards,
    Bill

  • I've changed to the latest version of Cyclone_Launch.  We're still seeing the same intermittent error message.

  • Greetings,

    Is this still an issue? Has this problem been resolved?


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement