Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink Universal and CodeWarrior 10.6.4
Thomas V. Nov 19, 2015 at 01:25 AM (01:25 hours)
Staff: Takao Y.

  • Hello,

    I'm relatively new to P&E tools, so please forgive me if this is the wrong venue for this.

    I have a K20 processor I'm trying to program using CodeWarrior, but unable to.

    I get a dialog box indicating that a interface hardware or target connection could not be made. When I cancel out of that, I get an error message saying:

    Error: Connect Failed.
    Can't connect. The Debugger can not connect to the PE device(ARM GDI Protocol Adapter)
    Error: Connect Failed.

    In the console, I see this:

    fl::target -lc "LC for Simple Flash"
    fl::target -b 0x20000000 0x8000
    fl::target -v off -l off
    cmdwin::fl::device -d "FTFL_PFlash256" -o "64Kx32x1" -a 0x0 0x3ffff
    cmdwin::fl::erase all
    Beginning Operation ...
    Performing target initialization ...
    Error: Connect Failed.
    Can't connect. The Debugger can not connect to the P&E device(ARM GDI Protocol Adapter)
    Error: Connect Failed.

    I'm running on Windows 10 64bit. Jungo Drivers look like they load fine. Anything else I need to check?

    When I first tried this, it did say that the firmware was out of date and updated it. But it seemed to go fine. May be not?

    So my real question is: Is this a problem with connecting between the P&E device and the Windows PC -- OR -- Is this a problem connecting between the P&E device and the target processor?

    How can I diagnose the problem?

    I'm basically trying to use the "Flash Programmer" built into CodeWarrior. If there is some way to diagnose the problem and show that the hardware device is working correctly, I would happily buy the stand alone programming software and use that. But right now it looks like the hardware is broken.

    Thank you in advance.

    Best Regards,
    Tom Varghese


  • Greetings,

    The error indicates the problem is the software is not able to detect your multilink.

    First, I want you to create a new project within Codewarrior for your chip. Compile this project and try to debug it. What this does is creates a set of configurations to work with your multilink. If the debugging is successful, then switch over to the "flash programmer" designed by Freescale. Create a new task and set your target settings to the one used in your debug session I made you do. This should resolve the issue of the task not being able to find your multilink.

    Takao Yamada

    • Hello,

      Sorry for the late response. But the system behaves the same way when doing debug too. So is something wrong with the PC software and/or the hardware?

      How can I isolate the problem?

      I created the project just as you suggested. Here is what I did:

      1) New Project :
      Named it test4
      Selected the MK20DX256 processor.
      Connection to be used: P&E USB MultiLink Universal [FX]/ USB MultiLink
      Language: C
      Floating Point: Software
      I/O Support: UART (default)
      ARM Build Tools: GCC
      used default values for the reset of the setup

      2) Project Properties:
      Run/Debug Settings: Created a new configuration
      Interface: "USB MultiLink, USB MultiLink FX, Embedded OSBDM/JTAG..."
      Port: USB1: "MultiLink Universal Rev C (PEM1349A9)"
      used default settings for all the rest.

      3) Run the Debug.

      I get the same error:
      Error launching test4 RAM
      ARM GDI Protocol Adapter : Can't connect. The Debugger can not connect to the P&E device

      Any clues?

      Thank you!

      • Sorry, also forgot to mention that the interface and port are populated as you had mentioned. Which means that the drivers are properly installed and detected.

  • Greetings,

    Let us check drivers. Go to your device manager and make sure the following items are showing up:

    Jungo -> WinDriver -> Properties -> Version 11 or higher
    Jungo -> USB Multilink 2.0

    Both must exist for it to work correctly. If they do not, please download the latest drivers from our website:

    Then go to your project in Codewarrior and right-click on your project -> Debug As -> Debug Configurations. A new dialog will open. Left column select your project for RAM or Flash does not matter. Right column go to main tab and look for Connections. You should see an "Edit" button. Click on it and you will find our configurations.

    Make sure the interface is for multilink and that for Port you see your multilink populated there. If nothing shows up, then this is why the debugger cannot find your P&E hardware. We will need to do more investigation if that is the case.

    Takao Yamada

    • It was there just fine but older version 11.x.x.x.  So I uninstalled them, installed the new drivers. 

      Still no luck, exact same errors.

      Thanks for your help so far. Any more ideas?

      • Just so we are clear on this, I'm using the free version of CodeWarrior. Version 10.6.4.


  • Could it be that the module is toast?  It does get very warm.  Or is this normal?


  • Greetings,

    Your multilink should not get warm. Do you smell any burning?

    It does matter if you are using the demo version of Codewarrior. It should still work.

    You need to decide if your multilink is broken. Try using this updater utility. If this does not work, then your multilink is most likely damaged:

    Takao Yamada

    • Hello,

      It has been like this since I got it. I've only plugged it in a few times and it has always been warm. Was tempted to take it apart and see what was hot, but it did not look like it could be disassembled easily. So I didn't.

      I've used other JTAG devices that have a PowerPC processor in it, so didn't think anything of the heat at first.

      There is a slight smell, like that of fresh PCBs off the assembly line, like a solvent smell. May be that is not solvent!

      I'll try the digikey route and see what happens.


      • Greetings,

        The multilink's enclosure can be disassembled with some force and it will not break or get damaged. You should definitely look for any damages and get it fixed. It should not get warm at all.

        Takao Yamada

  • Hello, 

    I have exactly the same issue. Using CodeWarrior 10.7, I can configure the interface / port as required (Using Multilink Universal) but then when I run or try to program the target, I get the "ARM GDI Protocol Adapter : Can't connect. The Debugger can not connect to the P&E device".

    Otherwise the drivers are all installed and I am even able to update/reprogram the Multilink device firmware using the P&E utility.

    Any ideas why CodeWarrior is not able to connect to the interface?

    • Greetings,

      Has this setup worked in the past, or is this your first attempt? If this is not your first, then what has changed since?

      Make sure your multilink is not being used in other software, that you are not using a USB hub, and that both yellow and blue LEDs are lit. Also try installing the latest drivers from our website:

      Otherwise, there are not much else to get the software to connect so I am puzzled. I have tried the software on my end with no issues.

      Please indicate which multilink universal revision you are using.

      Takao Yamada

  • Hi, 

    I have exactly the same issue. Using Code Warrior 10.6, I can configure the interface / port as required (Using Multi link Universal) but then when I run or try to program the target,

    Error: Connect Failed.
    Can't connect. The Debugger can not connect to the P&E device(ARM GDI Protocol Adapter)
    Error: Connect Failed.

    Im using Multilink Universal Rev C

    pls give me any suggesstions.

  • Greetings,

    Did you follow my advice that I have given to the original poster? Did you download the multilink resource CD to get the latest firmware? I would advise to also update your Codewarrior to the latest by going to Help -> Check for updates.

    Takao Yamada

  • Hi,

    I had the same issue with a Multilink I recently received. But I ran the updater utility as you pointed out above and started working normally. It seems that the windows drivers I already had were newer as the firmware inside the debugger. Thank you for the tip!


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement