Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
multilink universal does not recognize the "XBIB-U Dev Rev 3" card MAXTREAM
Andres A. Nov 15, 2015 at 12:35 PM (12:35 hours)
Staff: Takao Y.

  • multilink universal does not recognize the "XBIB-U Dev Rev 3" card MAXTREAM

    Hello. I need to know if "universal multilink" is damaged or not working properly but there is adequate communication configuration.

    CodeWarrior perfectly detects the port UNIVERSAL MULTILIN because blue LED lights

    MULTILINK amber LED lights when the XBIB card connects via USB connection to the PC

    before, with Multilink disconnected and offline XBIB I connected the cable 6 wires.

    6-wire cable is properly and securely placed.

    'I've tested with CodeWarrior 6.3 on an XP x32 PC

    -and I tested with CodeWarrior 10 on a PC W7 x64

    I tested with two XBIB cards:

    - XBIB-U

    (Recently purchased another card rule because I read on the official website of DigiKey you can have a failure in the connection serial port)

    I tested with two types of programmable modules XBEE:


    I have updated all drivers XCTU

    I tested with API XBEE mode and AT mode

    I tried it with speed serial XBEE 9600 and 115200 and 34800

    I tried updating the firmware XBEE


    the test result is always the same:

    "The target MCU is not responding. Please turn off power mcu (under 0.1 v9, turn power on, and then a click on OK, This Will Attempt to enter debug mode Through to power on reset sequence (bkgd currently is driven low)

    after performing this operation comes another box that puts Dialgo

    "An error occured while connecting to the interface specified in hardware or target of launch configuration dialog. For This launch, May retry-you specify the connection With the following parameters"

    Agradeceria si alguien pudiera indicarme alguna solucion


  • I would appreciate if someone could tell me some solution

  • Greetings,

    Why are you using our tools to program an XBEE chip? Where did you read that Codewarrior and P&E tools would do this?

    Codewarrior 6.3 and 10.x are for Freescale chips. P&E's interface works with Codewarrior to flash program and debug Freescale chips. Your XBEE is not supported.

    Are you actually programming the XBEE, or is there a microprocessor on this board that I am not seeing?

    Takao Yamada

  • Greetings,

    So if you were to create a brand new QE32 project within Codewarrior and try to program the XBee without any code or setting changes, does it work? I am trying to rule out any modifications you had to make to get your code to work in Codewarrior and with the XBee.

    If this basic setup does not work, then trying to get XBee to work is beyond the scope of Codewarrior and P&E's support. Was it recommended by Freescale to use Codewarrior and P&E tools to get this working? It sounds like a huge investment into a project you are not sure if it would work.

    Also note, that QE32 has much smaller RAM and flash. Trying to program your XBee is going to be significantly reduced in available memory space even if you get it working correctly. You would need to get a custom algorithm from us to be able to support the higher flash addresses, but let's cross that river when we get to it.

    Takao Yamada

  • Thanks for your attention and patience. In fact. In the STARTER GUIDE to operate the XBEE PROGRAMMABLE from digikey recommend CODEWARRIOR software and hardware MULTILINK. In the STARTER GUIDE of digikey, are given precise instructions to load a new bootloader on MC9S08QE32 FREESCALE chip built-in module XBEE. There is even a plugin for running with CODEWARRIOR XBEE 10.2. In my case, everything works fine, until having to load the code in the MC9S08QE32 chip installed in the XBEE module, which is done via a 6-pin RIBBON connection with XBIB-U card in the which in turn, it is the module with the MC9S08QE32 XBEE chip. probably a configuration problem. but I want to also rule out the possibility that MULTILINK UNIVERSAL malfunction.

  • Greetings,

    I want you to install the following tools to make sure you have the latest firmware for your multilink universal:

    For the 9S08QE32 the setup is very simple and there is nothing unique you need to do to get it working in Codewarrior. I hope the firmware update I gave you may resolve your issue.

    Takao Yamada

  • Hola
    he actualizado correctamente MULTILINK. pero desgraciadamente el problema continua...

  • I updated with multilink link but the problem persists ...

  • Greetings,

    I am not going to be able to reproduce this problem since I do not have this board. Do you happen to have any other HCS08 or other Freescale chips to confirm that your multilink is in working condition? If we can rule out the hardware problem, then what you can do is maybe contact Digikey to figure out what you may be doing wrong to get this working.

    Did you try my suggestion of creating a new project for QE32 and see if you are able to connect and flash program the chip? This is a crucial first step to finding out if you will be able to continue on this project.

    Takao Yamada

  • Hi all,

    I am facing the same problem and i have tried using the xbee bootloader example program to flash it but the result is the same:-

    "The target MCU is not responding. Please turn off power mcu (under 0.1 v9, turn power on, and then a click on OK, This Will Attempt to enter debug mode Through to power on reset sequence (bkgd currently is driven low).

    Any help please?

  • Hello. I could not yet solve the problem. I have observed that "pemicro" tab in the "CodeWarrior 10v2" is not activated. however, the program recognizes universal multilinck. Could this be the cause of the problem ?. in that case, how the "pemicro" tab is active ?.

  • Greetings,

    That tab you are talking about will only enable if you get a debug session working. But it does not indicate that you do not have the support. You need to get past the "target MCU not responding" problem first.

    Could you get a multimeter and measure the following pins on the 6-pin header on your board (disconnect any P&E devices):
    a) Pin 1, BKGD
    b) Pin 4, RESET
    c) Pin 6, VDD

    Measure against pin 2, which is GND. What you should be seeing is that if your chip is powered up these pins should all be 5V (or 3V if the chip only supports this voltage). If any of the pins are not high, then you have a problem on the board side.

    If you have an oscilloscope, what you should be seeing is when you connect the P&E device and try talking to it, the following steps should occur in order:
    1) BKGD, RESET, and VDD is high. VDD should always be high.
    2) When you click on connect, BKGD and RESET both go low (zero volts)
    3) RESET signal goes up, while BKGD stays low. This is when debug mode has been entered.
    4) Lots of pulses on BKGD indicates communication is successful.

    People who have this problem usually make a few mistakes:
    a) Forget to connect VDD pin. This is the reference voltage and must be connected. It may provide power to your target if the P&E device supports it and you set the correct jumper settings and software settings to do so.
    b) Put resistors in series on BKGD and RESET lines for current-limiting protection, which drops the voltage on these signals to not allow the full 5V reading. Remove these resistors. If still not reaching 5V, then you may want to put a 10K pull up resistor on BKGD and/or RESET.
    c) There is an external watchdog. It is triggering the RESET line constantly and not allowing the P&E device to properly connect to the chip. You may need to look for schematics of the board and within the chip design.

    Takao Yamada

  • Thanks for your specific answer. I was being very useful. I checked my card pins and measure voltage between pin "1-BKGD" and "2-GND" pin results in zero volts. if the state of the pin "1-BKGD" has to be high, there should be some indication of the configuration of the card or the XBEE-programmable module that have not taken into account. if a user of this forum has information on this issue, I would appreciate your input. I tried three different cards, always with the same negative result. such cards, all work correctly with non-programmable modules. so I think that the cards are not damaged. I have also tried several xbee-Progammable, "XBEE2B" Y "XBEE2C" modules.that they have been properly recognized by the X-CTU software company DIGI.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement