Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Multilink universal "can't commmunicate with target processor MK21FX512VLQ12 and MK60DN512ZVLQ10!"
Jaroslav C. Nov 5, 2015 at 03:58 AM (03:58 hours)
Staff: Gerardo R.

  • I am using processors MK10DN128VLH5 64pin, MK61FN1M0VMJ15 256pin BGA a MK60DN512ZVLQ10 144pin and programmer PE MUltilink universal. Every processor is used on variety PCBs. Currently I have problem with processor MK60DN512ZVLQ10, when I run Debug it can't find device. IDE CW10.5, CW10.6 i KDS3.0 behave all same way: print screen??

    Because of this issue I had in our company a visitor from Freescale 2 years ago. He could not find anything so he wanted to log process of connecting to device after Debug was turn on. So he turned on logging: print screen??

    Suddenly all was OK and working properly. After he turned off logging, IDE was not able to connect to device. I have settled with always having logging turned on. Exact same behavior was on 3 different PCB (different projects). Now after 2 years I start using processor MK21FX512VLQ12 144pin. It behaves same way as MK60DN512ZVLQ10 so I have to have logging turned on. I want to start using latest version of IDE (KDS3.0) but I cannot find that "logging option" anywhere so I am not able to connect to processor.
    From my point of view there are two options:
    1) FInd out why has to be turned on logging so I could turn it off (maybe it could be releated with 144 pin version of processor)
    2) Show me or tell me how I will turn on logging on KDS3.0. Perhaps it will start working same way as CW10.6.




    Comments

    • That is very strange. You can try adding the option "-outputdebugfile" to the GDB Server parameters to enable the same flags in our software.

  • We have try to add this parameter to KDS 3.0 (Debug -> Debugger -> GDB Server Setting -> Server Parameters -> -outputdebugfile). I does not have any effect there is same error as before.

  • I don't know if this is related, but today I suddenly started having serious debug issues with KDS3.0 with a Multilink Universal and Kinetis K22 device. I had some debug bring-up issues about 1 month ago (with 3 custom boards) but suddenly SWD debugging started working (not using JTAG on this board) and has been stable (until today).

    Today, I was unable to debug any of the 3 prototype boards. I was getting a wide range of errors when attempting to connect and debug. The same tool config still worked with another custom Kinetis board which was strange.

    Finally, when scoping SWD , I noticed significant overshoot and ringing on SWCLK. SWDIO signals looked great. With the scope connected to SWCLK debugging started working. Added a 33pF capacitor to SWCLK and suddenly after 5 hours troubleshooting, all 3 boards have stable debug operation.

    These are 2 layer boards, with short traces to debug connector. SWD operation seems to require some SWCLK to GND capacitance to tame SWCLK. Not sure what sort of buffer/driver is inside multilink or if there's any slew-rate control, but it seems like a very aggressive output driver in SWD mode anyway.

    • Hello Jon,
      I have tried to connect 33pF to SWCLK. PCB with K21 which was not working properly is OK now. I will try this with rest of PCB and with K60 as well. So far it seems that your advice helped.

      Thank you

  • Glad to hear that worked!

    My boards continue to work well with 33pF however on the next board revision I'm going to add provision for a low-value series resistor too, since that may be a better option for controlling the ringing.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement