Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
ML-Universal "Can't comunicate to target processor"
Roberto G. Nov 4, 2015 at 02:38 AM (02:38 hours)
Staff: Kevin M.

  • I've bought a USB-ML-Universal rev C. I want to use it with Codewarrior 6.3 on Windows XP virtual Machine with a HCS08AW micro. I have upgraded windows driver ( version) but when I try to connect with target Device the Multilink dosn'work ("Can't comunicate to target processor! Please chek your connections between the cable and the target and make sure the target has power"). I checked power, I changed the cable and all is ok. With Oscilloscope I see that the signal RESET (pin 4 of cable) is always 5 Volt (I don't see any GND pulse). With an old USB HCS08/HCS12 Multilink I don't have any problems. What can I do for fixing my problem?



  • Greetings,

    Virtual machines can be tricky. Do you have the drivers installed on both the host and virtual machine? This is key in that the host must be able to detect the multilink before you can transfer it over to the virtual machine.

    When you said this has no problem with the old multilink, is that with the virtual machine, or when you used to use it with a native XP machine?

    Also, I advise not using a virtual machine when using CW6.3. Nowadays people are using them on the host machine and successfully getting them to work using the patch I have created:

    Takao Yamada

    • Hi,
      I got the same problem of Roberto. With IAR workbench, when I try to download the project to my hardware using a USB-ML-Universal rev C, I got "Can't comunicate to target processor! Please chek your connections between the cable and the target and make sure the target has power".

      I tried with a USB-ML-Universal rev B, and it works fine, so I guess there's no problem with the cables or hardware.

      Do you have any idea how to fix this?

      Thank you.


    • Hi,
      I try to answer to your question:
      1. I have installed the drivers on both the host and the virtual machine.
      2. The old multilink works well when I use it on virtual machine
      3. I have tried your patch, but the result is worse: the program is not able to see the Multilink (Port"Undetected. Disconnect/connect USB cable. Click Refresh List").

      I tried USB-ML -Universal rev C with a native XP machine: It doesn't work. As I said in the previous comment, the problem seems to be the connection with the target, not the connection with the PC: I see the signal on BGND pin, but I don't see any pulse on Reset pin. Could it be a hardware problem?

      Thank you,

  • Greetings,

    For the USB-ML-Universal, please download this firmware updater utility and update the firmware to the latest version. This could resolve the issue:

    If not, then there could be a hardware issue.

    Takao Yamada

    • I executed the software in the host PC, but ML has not worked yet.

      I tried to executed the software in the virtual Machine but I had an error (“Failed to install the INF file (C:\Program Files\PEMicro\multilink_universal\Drivers_11_7_0\windriver\windrvr6.inf. LOG ERROR(3): error 800b010a, Signature verification failed while checking integrity of driver package ‘windrvr6.inf’).

      Then I tried to update the driver directly from Control panel of windows XP selecting the folder “Drivers_11_7_0\windriver” of windows 7, but I had an error (“impossible to install the driver: the driver can not install on this piattaforma”).

      Then I executed the software on a PC with native Windows XP: the ML doesn’t connect the target yet.

      what can I do now?


      • Try following the procedure outlined in this FAQ:

        • I followed the procedure: I executed the program for updating the Root Certificates. Now I don't have problems when I execute the program "PEDrivers_install.exe", but the MultiLink have the same problems. Now the USB Multilink 2.0 driver version is, the WinDiver driver version is
          I have checked Reset Signal again: I don't see any Ground pulse (with rev B Multilink I see pulse when I connect ML to target).
          How can I be sure that is not an Harware problem? And if it is a hardaware problem How can I replace Tle Multilink?

          Thank you.

  • greetings, I have the same problem: multi link is not brought into contact with the card. the card is XBIB-U-DEV and the Freescale chip is embedded in a module XBEE. try to update the "bootleader" the XBEE to program the chip MC9S08QE32CFT leading multilink including but not connected with the card. I updated the latest firmware multilink advised in this thread. the computer works on Windows XP x32. multilink blue light is on and the yellow too. Is there a specific configuration is required XBEE? How I can know if not a hardware problem multilink?

    • Does the mutlilink not enumerate? (check the jungo tab of device manger)

      • jungo device works properly. version. CodeWarrior plugin program xbee multilink recognized correctly. everything seems correct. but multilink not recognize the card where this since the programmable XBee all well but when I press "run", 1 get a popup that says "the target MCU is not responding. Please turn off power mcu (under 0.1 v9, turn power on, and then a click ok, This Will Attempt to enter Through debug mode to power on reset sequence (bkgd currently is driven low) .... but after doing this, it comes another popup that says "an error occured while connecting to the interface specified in hardware or target of launch configuration dialog. For This launch, May retry-you specify the connection With the following parameters" "USB multilink - USB port" "multilink universal rev or c on usb1 (name = PEM4A2ABB)" I give the button "retry" and returns to the first window ¿?

  • We bought this Multilink Universal REV C "Blue" 4 units, none of them works. But our "Green"old one works well No use if we update the latest driver. Please advise as our case is exactly same as this one. Thanks!


  • because that my ignorance  not have  limit
    the more obvius thing, it not useless for me

    i was working with xbee that not was programmable

    the programmable xbee have a "B" but immediately before the last numbers

    so "pro s2b" does not mean that is programmable..... "...B004.. " or ".... B003.." in the end of the sausage of words, yes

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement