Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
USB PPC NEXUS Multilink can't connect to MPC5674F
Marc H. Oct 20, 2015 at 10:47 AM (10:47 hours)
Staff: Takao Y.

  • I'm trying to use my USB-ML_PPNEXUS to connect to an MPC5674F in a new board design. The PPCNEXUS works with an existing MPC5554 design.

    When I connect to the target, the yellow light does not come on. The processor's reset line is being pulled low, but I see no activity on any of the JTAG signals.

    The message on PROGPPCNEXUS app is "Cannot enter background mode."

    PROGPPCNEXUS Programmer Version
    USB-ML_PPCJTAG Flash Version 5.08

    What should I look at to debug this problem? Thanks in advance.


    • Hello Marc,

      Did you ever solve this problem.
      I'm curious because I seem to be having a similar problem.

      If you solved it, what was the solution.

      Best regards,

  • Greetings,

    If the yellow LED is not turned on, that means the multilink does not detect power on your board and will guarantee fail flash programming. You should make sure you can see 5V on the VDD line on the JTAG.

    Takao Yamada

    • Thanks, Takao. This really narrows down the problem.

      I checked and found I have 3.3V on the connector, not 5V. I've always used 3.3V on my MPC55XX JTAG connectors and never had trouble before. The 5674 JTAG pins are associated with VDDE2, which I'm also running at 3.3V.

      Maybe I have a problem in my wiring, though. I'm using a new connector type and a funky adapter board between the pod and the target board.

  • Greetings,

    I think I have a similar problem. I'm using a PEmicro USB Multilink (PART#: USB-ML-PPCNEXUS which came with the MPC567XEVBMB and MPC567XADAT516 Eval Kit from Freescale/Axiom) to program a Freescale/AVX PPC MPC5675K on the Axiom CMM-5675 development board.

    The blue LED comes on when I connect the Multilink to the PC and the yellow LED comes on when I connect the Multilink to the JTAG connector on the CMM-5675 dev board. But, I can not get the flash programming software to connect to the target. I've tried it from CodeWarrior by clicking the debug button and from the "C:\PEMicro\PKGPPCNEXUSSTARTER\WINIDE32_64K.EXE" tool by clicking the 'lightning bolt' flash programming button.

    The schematic for the CMM-5675 says that Vcc on the JTAG connector is 3.3v.

    So is this a show-stopper? Is this the wrong programmer for this dev. board? Do I need a 3.3v version of the Multilink?

    Marc H.: What was the resolution to your issue in the original post on this thread? Did you get it working? What was the solution?

    Any assistance would be greatly appreciated.


    Axiom CMM-5675 development board:

    • Hi, Bryan. The resolution to my problem was to figure out with Takao's help that the wiring of my JTAG connector was scrambled.

      • Ah, ok.  Thank you.

  • Greetings,

    There is no such thing as a 3.3v version of multilink. The multilink can handle 3.3V or 5V with no issue as long as the VDD line is connected between the chip's MCU and the multilink via the ribbon cable. The VDD is the reference voltage for the other signals so that the multilink knows that 3.3V is high for 3.3V parts and not high for 5V parts.

    One setting that customers need to test out first is the shift frequency. This is often found during hardware setup in software and you should slow down the frequency.

    Make sure BOTH blue and yellow LED is lit on the multilink and that you are not using any custom adapters, ribbon cables, or other unique hardware that may be causing noise or disturbing the signals. If you are not connecting all 14-pins of JTAG, then that could be a cause for problems as well.

    Takao Yamada

    • Hello Takao,

      Thanks for the quick response. At least I know I have the right hardware.
      I am not using any custom hardware -- no custom cables nor interconnects.

      I am also getting this error message:
      "Error in ONCE status register during instruction execution"
      which seems very similar to this post:

      which says:

      Johnny: "MPC5675K support was added to PROGPPCNEXUS in version 1.38. You can download the latest Starter Edition from the PKGPPCNEXUS product page."

      Jesper: "Thanks Johnny, that did it. Works perfectly. Someone really should tell Freescale this, so they don't ship a useless tool with their EVB causing both lost hair and time for their customers!"

      All the software I'm using was downloaded recently so, I would think I have the latest, but perhaps this component is old... I am going to download this now and give it a try:

      P&E's PROGPPCNEXUS BDM Programmer software

      I'll let you know how it goes...


      • Hello Takao,

        It's still not connecting.
        I upgraded the PROGPPCNEXUS software and I still get the same results:
        "can't communicate with target"

        shift frequency: I tried each selection for the sift frequency, including the slowest setting.

        LEDs: Yes, BOTH the blue and yellow LEDs are lit on the multilink (and as I said, I'm not using any custom adapters, cables or other custom hardware.

        JTAG connector: I am connecting all 14-pins. I have simply plugged the female connector on the multilink into the male header-pin connector on the CMM-5675 dev board. I'm pretty sure I have the polarity correct. I have the red stripe on the multilink ribbon cable facing the power input side of the dev board.

        Is there any possibility that I need to update the firmware inside the USB Multilink?

        Best regards,

  • Greetings,

    Your multilink USB-ML-PPCNEXUS has not changed firmware in ages. I doubt the problem has to do with needing new firmware. If you downloaded the latest software from us, then it would have auto-updated to the newest firmware on your multilink for you anyways.

    Try adding a 200ms reset delay in hardware setup and connection.

    Have you used this multilink in other projects and had success before? We have to determine if this is a multilink problem or device/board problem.

    Takao Yamada

  • OK, I am now able to connect to the MPC5675K target on the Axiom CMM-5675 development board using the PROGPPCNEXUS software from P&E Micro.

    The problem seemed to be some kind of conflict between the USB to serial drivers recommended by Axiom to connect to the USB port on the CMM-5675:

    Windows x64 drivers from here:

    and the USB driver recommended by P&E Micro to use the USB Multilink Interface device:

    P&E Hardware Interface Drivers, Version 12 (Win XP/Vista/7/8/10) from here:

    What I did was:
    1) I uninstalled the PEmicro driver.
    2) Then I re-installed the FTDI drivers and connected to the CMM board using TeraTerm -- I was able to run the built in diagnostics to verify that I was indeed connected (AXM-0591 (CMM-5675) Diagnostic Program -- Mar 25 2015).
    3) Then, with the CMM board connected, I re-installed the PEmicro drivers. The Windows7 Device Manager then showed the PEmicro drivers under the Jungo entry and the USB Serial Ports under the Ports entry all showing simultaneously.
    4) I then ran PROGPPCNEXUS and was able to connect and execute some commands: blank check, erase, upload... I have yet to figure out how to download a binary image to the internal flash though.

    Does PROGPPCNEXUS only program hex files to the target? What I have is a .bin file -- two of them actually. They are just binary images. I want to program one of them at address 0x00000000 and the other one at address 0x00020000. Then I need to program a MAC address at address 0x001FC000.

    Any advice on that would be warmly welcomed.


  • Greetings,

    Wonderful, you have made great progress!

    Our software can take ELF, Hex, and S19 files. Raw binary files like .bin. Did you compile the project, or were you just given these files? If you did compile, you should check your compiler settings to see if it can generate other file formats to fit your needs.

    Otherwise, you will need to do some manual conversion using our BIN2S19 utility:

    Once you have the right file formats, you should call the PM (program module) command to program and VC (Verify checksum) command to confirm it was completely programmed.

    MAC Addresses is a different story. My assumption is that you need to program different addresses for every chip/board. You may want to look into our serialize utility to create a serial file at a specific address and counter mechanism:

    For serial files you can call the CS (Choose serial) command to select your serial file and PS (program serial) to program the serial number.

    However, if you must write different values for MAC addresses that do not follow any kind of pattern, then you need to do dynamic programming. That involves the use of our Cyclone Automated Control Package:

    You can download our basic trial edition, but it will not allow you to program dynamic data until you buy the professional or enterprise version.

    Takao Yamada

  • Hello Takao,

    Thank you for the link to the conversion tool.

    I was able to convert both images to .S19 but now I think I'm bumping up against the "free software limits".

    My first image is a little more than 24 Kbytes. That one seemed to program OK.
    My second image is about 1,000 Kbytes. For this one, I'm getting error messages.

    It looks like the tool only lets me program one image at a time (it forces me to erase before each re-programming) and it seems that the second image is too big.

    Can you confirm this is the case? What do I need to do/buy to be able to program images of unlimited size to the target?

    Best regards,

    p.s. I am compiling the images myself. I will see if I can generate .S19 files...

    Status window messages:
    Programming Address $00006000. Programmed.
    Error - Demo software only - number of PM commands exceeded. Use EM (Erase Module) to clear.
    Erasing. Module has been erased.
    Checking range of S records. Checked.
    Programming Address $ Error - out of memory.
    . Error during programming.

  • Greetings,

    Yes, the error you have mentioned does involve reaching the 64K limit of the demo software. And the demo software does only allow you to load one item. Otherwise people could get around the 64K limit by simply loading less than 64K at a time.

    You will need to purchase a full license from us:

    Once you purchase a license, we will send you a download link to the software (you already have it installed) and a license key. You can activate the full license by opening up your current PROG software and go to the Help Menu -> Activate software.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement