Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
USB Multilink universal no longer works .... replacement required ?
. Oct 20, 2015 at 05:02 AM (05:02 hours)
Staff: Takao Y.

  • Hallo PEMICRO-Support,
    we use a PE Micro USB Multilink that actually no longer works, presumable damaged by ESD-voltage.
    Can you offer me a modul in replacement, only the hardware, software PROG32Z works well
    We are using <Motorola-683xx-format>....for a rather old DUT assembly.
    Unfortunately you don't offer on your PEMICRO-Website this (old) 683xx Device.
    How shoud we proceed? Thanks for your reply.

    ------------------------------------------------------------------------------
    Best regards
    burster praezisionsmesstechnik gmbh & co kg




    Comments

  • Greetings,

    I had to remove your contact, your installation code, and order number for your own protection. This is a public forum. If you want spam emails, spam calls, and stolen software license then I can add your information back onto the forum.

    Please create a support ticket (Support page -> Support requests) to request for an RMA. You will need to detail how the unit is broken. Are there burnt components? Does it no longer show up in device manager? Do you have the correct firmware on the multilink?


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement