Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Windriver not loading
David S. Oct 7, 2015 at 04:57 PM (16:57 hours)
Staff: Kevin M.

  • I had tried installing the OSJTAG driver for the Freescale Kinetis K20D50M board.  It failed to install, but it broke the Multilink Universal FX I had installed.  Now I no longer see Windriver loading under Jungo devices, it only shows the Multilink.  I tried uninstalling the OSJTAG driver, and the Multilink driver.  When I tried installing the Multilink FX again, now it says it can't uninstall the windriver, and it can't install it either.  It won't load, so I can't do anything with it.




    Comments

  • David,

    What error do you see when you try to reinstall the driver?

    What operating system are you using?

    Best,

    Kevvin

    • Hi Kevin, the errors I get are:

      Failed to uninstall the INF file c:\program files(x86)\pemicro\multilink_universal\Drivers\windriver\windrvr6.inf

      Log error(3):error 2, could not uninstall c:\windows\inf\oem170.inf

      followed by

      Failed to install the INF file c:\program files(x86)\pemicro\multilink_universal\drivers\windriver\windrvr6.inf

      log error(3):error 2, return updatedriverfor plugandplaydevices

      There's lots more text, but I can't attach a screen shot of all these errors.

      This is Windows 7 Professional 64-bit.

      I did find a way to install windrvr6.inf manually.

  • Looks like you have an older installer that is not supported on 64 bit. What is the version of the software that you are trying to install?

    • Hi Kevin, the properties for mutlilink_universal_install show version 1.0.0.0, and this has been working fine on 64-bit.  It was after I tried to install the OSJTAG driver that it broke.

  • David,

    Can you try installing the latest drivers?

    Thanks,

    Kevin

    http://www.pemicro.com/downloads/download_file.cfm?download_id=301

  • We've tried using version 12, but those drivers do not work with the debugger in Kinetis Design Studio 3.0.  We can only get the debugger to work with version 11.7.

  • David, 

    I followed up with you about a week ago in an email. Did you receive this?

    Best,

    Kevin

  • No, I haven't seen it.  For now, it is working if I install Windriver manually, and I'll stick with 11.7.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement