Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
ELF error writting code
Rene V. Aug 12, 2015 at 01:44 PM (13:44 hours)
Staff: Takao Y.

  • Hi,

    I have a problem loading the program to the MCU, because when try to load the compiled code into the flash memory, appears the error.:

    ELF Loader: Error while writing to 4000h ... 4200h
    Information no memory at this address.

    The behavior is abnormal because previously I have been doing the same procedure, but with the result of a successful load on the MCU firmware.
    Maybe a sector of the flash is corrupt?
    What does the error?
    Why could Happen error?

    Thank you very much for your help,

    CoderWarrior 5.9
    P&E Micro USB Multilink Interface


  • Greetings,

    Try creating a default blank project for your device. If it succeeds in flash programming, then you know the issue in within the project. If it does not program, then there was probably a change in either firmware or hardware that is causing this problem.

    Takao Yamada

    • Hi Takao, 

      Thanks for your help, was very useful. I tried with another project and works!, so i suppose that the project was corrupted. By another hand, i'm using just a folder that contains the project but it wasn't have the .xml file (from import project) and followings warnings was displayed:

      The following access path in target "P&E ICD" of project "proyecto" cannot be found:
      The following access path in target "Simulator of project "proyecto" cannot be found:

      And i think that a lack of path for Processor Expert could be corrupting the project. What do you think?

      Best Regards,

  • Greetings,

    Did the project have any "MCP" file? All of the classic Codewarrior projects use this MCP file to hold the project structure and settings. Without it, it would be impossible to import into your workspace. Not sure how you got this working in the past.

    If there is no MCP file, you are probably working with a Codewarrior 10.x project based on Eclipse.

    Takao Yamada

    • Hi Takao, 

      Yes, of course that the .mcp exist and this is how i open the project and compile. But when i make the project, and it was compiled without problems, i didn't activate the Processor Expert. I think that the PE could have been problematic.

      My apologies because i' m new in this suite development.

  • Greetings,

    Any update on this?

    Takao Yamada

  • Hi Folks,
    sorry for the reply to an old thread.
    Maybe anyone helps my answer.

    On my old PC in the firm I used Codewarrior V6.2SE.
    I had a project where I used Device Initializaton with a HCS08GT16A, plain assembler.

    Now at home I tried to do some modifications to the project. Because I like the Device Intialisation tool, I've installed CW V6.3SE (on Win7 Ultimate 64Bit, see ""; for details how to do that).

    I loaded the .mcp and everything worked. Since I had to change some module settings, I've used DI again and let the tool generate the code with the changed module settings. Then I've tried to flash the changed firmware. Then I've got a similar error as above named. The flash tool said also that it cannot write above 0x10000 because there is no memory (that's correct as the memory ends at 0xFFFF).
    I've searched the INet, but didn't find anything about that effect. Then I had a look on the generated files. And really there should be code above 0xFFFF!
    Then I had a look at the generated MCUinit.asm...
    The "isrVrti" which was the first ISR before all the others was not there...
    it was now above the IRQ vector table. Moved back by hand at the usual place, everything works! Used the DI again, the isrVrti is again above the IRQ vector table. I think it is an an error in the DI of V6.3SE. I've never had this problem with the same .mcp (and others) CW V6.2SE.

    Maybe somebody has the same problem and this post helps him...

    Best regards,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement