Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cyclone Pro goes through complete program cycle, then says "failed to load"
Gary O. Aug 6, 2015 at 01:04 PM (13:04 hours)
Staff: Takao Y.

  • Hello again --

    This time I have a Freescale Small Engine Eval kit, which has an MC9S12P128 and a six pin connector that connects to my Cyclone Pro2. I am pretty sure I have the latest drivers for everything. I am using CodeWarrior Classic.

    When I hit debug, the True Time Real Time Debugger pops up, as does the Connection Manager window. I hit Connect, and it goes through the normal process, saying all the command files executed properly (they are all empty). But at the end, I get a window that says "Failed to load". When I close that, I can examine memory, and it looks plausible (zeros for RAM, FF for flash, random values for peripheral ports). So it appears to have a connection with the processor, but can't load a program.

    The eval board has a ceramic resonator. I am not that familiar with them; but its output does not look like any clock I have ever seen. The board is brand new, so should not have had the opportunity to be damaged in any way.

    So why would it fail to load the program? Does it need a better clock?


  • Greetings,

    Although you may be able to read memory, the problem may be that flash programming failed and all you are reading is the residual data in the chip from the previous time it was properly flashed.

    Are you sure you created the correct project? Usually the error you mentioned is due to some project configuration that was changed. I would suggest creating a new project for your chip and try flashing the default project.

    Takao Yamada

    • I should have been clearer that I was saying I could read memory, and that proved that I have contact with the processor.

      As to the correct project, I copied it verbatim off the DVD, but there are several other issues that lead me to believe that starting from scratch might not be a bad idea.

      Thanks for the prompt response. I'll let you know how it turns out.

  • Hello again --

    OK, so I created a new project, and imported all the files. It now compiles properly, which I am not certain it was doing before. When I click on Debug, the Connection Manager comes up, but it now says Port undetected. Disconnect/connect USB cable. Click Refresh List. (FAQ #29).

    As suggested in FAQ29, I have reloaded the Jungo drivers (even though they were not complaining about any problems), downloaded and run the driver test program. In addition, I have reset the CyclonePro, powered it off and back on, disconnected the target module, shut down all programs and rebooted the computer. Nothing makes any difference; I still get the Undetected message.

    This part was working yesterday.

    Even weirder, two other versions of CodeWarrior have no problem connecting and downloading. Neither of them uses the Connection Manager (or at least, the CM window doesn't appear).

    So... ?

  • Greetings,

    Good! You are at the point most people run into when using Classic Codewarrior. The last part they need is the patch I have created to fix this "Undetected" issue. Classic Codewarrior was built to work on XP 32 machines. My patch allows user to now use Windows 7/8/10 and 64-bit machines, and use P&E's latest hardware interfaces. Please check out this FAQ on how to get the patch:

    Let me know if this worked for you.

    Takao Yamada

  • I did all of that, and it didn't make any difference.  I should say that this computer is running XP.  Also, I couldn't find the dll in the PEMicro folder; it was only in the Windows/system32 folder.  I put the other files in there.

  • I got it figured out.  I hadn't noticed that the Connection Manager had defaulted to the wrong interface.  Oops.

    The program now loads properly, and does not say "failed to load", so all systems are Go for debug.

    Thanks for your help.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement