Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Issue using USB Multilink to program HSC12 after firmware update
Mobashar A. Aug 4, 2015 at 03:46 PM (15:46 hours)
Staff: Takao Y.

  • I have been able to use the USB Multilink Universal to program my Freescale HSC12 (MC9S12G64) without issue.  But after a firmware upgrade of the USB multilink (which automatically occurred when it was plugged in), it no longer works.  It gives me the following error message.

    Loading Target ...
    IO registers loaded for MC9S12G96 from C:\Program Files (x86)\Freescale\CWS12v5.1\Prog\REG\MCU01C3.REG
    Error 126 while loading library : C:\Program Files (x86)\Freescale\CWS12v5.1\Prog\PEOSBDMV1.DLL
    Error 126 while loading library : PEOSBDMV1.DLL
    Unable to load OSBDMDRIVER : PEOSBDMV1.DLL
    P&E Interface detected - Flash Version 6.15
    Startup command file does not exist.
    RUNNING

    I have tried to update the Multilink firmware again, using the firmware updater, but no help. I have tried re-installing PE Micro drivers, still no help. PLEASE HELP!!!!




    Comments

  • Greetings,

    Are you using Codewarrior? I suggest using one of our patches to update the Codewarrior. My guess is you are running into firmware and software incompatibility issue. The firmware you have is new with bug fixes and new features that the software is lacking. By patching it up, it will be synced up nicely:

    http://www.pemicro.com/faqs/faq_view.cfm?id=211


    Takao Yamada

  • I am using the hiwave.exe utility to load the code.  I only have the s19 file, not source code.  A supplier has provided this and instructed me to use the hiwave utility.  Will these patches still work?

  • Greetings,

    Yes, it will work. The hiwave uses our DLL to be able to communicate to the P&E interface. The patch includes new DLL and firmwares.


    Takao Yamada

  • There were a few different patches on that page.  I am assuming I should use the 
    'Patch for (S)12(X) 3rd Party Software', since I am using a S12 (Derivative: MC9S12G96), right?

    • Yes " Patch for (S)12(X) 3rd Party Software" is the correct one for CWS12v5.1. There is a readme file with instructions on how to apply the patch.

  • Greetings,

    Did the patch work?


    Takao Yamada

  • No it did not.  Any other ideas?  We are running out of time to get this up and running.

    If its possible, could we do a online meeting to try and resolve this. That way you could see my screen and directly diagnose.

  • Greetings,

    I gave you the patch 8 days ago. And now you are complaining you are running out of time?

    The patch we have available is the only solution we have.

    Are you sure you are selecting the multilink as your hardware? From the original post it indicates OSBDM as your hardware selection.

    I highly suggest you create a new project within Codewarrior and connect without any changes to settings. I bet it will work.


    Takao Yamada

  • We have been very busy trying to launch our production units and don't have time to sit around debugging this.  It was working fine till a firmware upgrade, which we did not initiate, happened and started giving us this error.

    We did not write the software we are flashing onto the S12 micro. This was done by our supplier. They provide the *.s19 file, which we flash on using hiwave.exe. So creating a new project within Codewarrior doesn't really help us.

    I think we have to roll-back the firmware to what it previously was, but I have no idea what the previous version is.

  • Greetings,

    Your P&E hardware interface must have been used on another project because the device would have not suddenly firmware upgrade within the same environment.

    Check with the USB Multilink resource CD and check the firmware on it. Make sure it can recognize your multilink and it is set for HCS08/RS08/HCS12 firmware:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=346

    If you have patched the Codewarrior correctly, then you should not have any problems. Within Hiwave, make sure you are selecting the USB Multilink as your interface.

    Redo the patch work again and make sure all the files are in the directory.


    Takao Yamada

  • We finally got it resolved.  thanks for support

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement