Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Problem Programming MKE04Z8VTG4
Robert R. Jul 31, 2015 at 10:57 AM (10:57 hours)
Staff: Takao Y.

  • I am trying to program a MKE04Z8VTG4 and I get a flash programming error.  In the console I can see it say the unit has been found, reset and the programming starts.  Then I can see where it says there is a CRC error in some block.  I have tried 3 boards and I get the same result on all three.  I am running the MKE04Z8VTG4 at 3.3V.  I can provide a schematic if requested.  I have a Multi-Link Universal unit (USZB-ML-UNIVERSAL) and am using Freescale Codewarrior 10.6.  I don't know how to log the console during the programming so I cannot show the specific error.  Any ideas?  Thank you,


  • Robert I sent you an email. I need to take a look at the schematics.



  • Greetings,

    Is this issue resolved?

    Takao Yamada

    • Yes, it was my fault.  The Flash registers between 0x400 and 0x40F are not really flash, I had some left over values there from the previous revision where I used a MKL02Z32 and it seems some bits on the MKE04Z4 are not programmable so I got a checksum error on the memory.  Thanks,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement