Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
DEMO9S08QG8 BDM wiped
James M. Jul 15, 2015 at 02:41 PM (14:41 hours)
Staff: Johnny N.

  • Yesterday I was programming an S12 device and accidentally had my DEMO9S08QG8 connected. Something re-programmed the P&E BDM firmware and now it is broken. (There was a popup in HIWAVE saying that the firmware was being updated with no option to prevent it.)

    How do I get the correct firmware back onto this device? I use it to programme 9S08QG8 devices and it has previously been very reliable at doing that. (I used it successfully yesterday before the mishap.)

    Now it shows up as a USB-ML12-? in the programming window.


    See also:


    • James,

      Did you have any success with the PROGHCS08 software?


  • James,

    I'm sending you a download link to a version of P&E's PROGHCS08 1K STARTER. Please try to communicate with your DEMO board using this software. If it doesn't work, let me know what it shows up as in the connection assistant screen.

    P&E Engineering Support

  • I downloaded and installed. The registration step didn't work, but it appears to have installed ok.

    The interactive programmer is giving the same dialogue and error message as through CodeWarrior.

    It shows:
    USB1: USB-ML-12 ? (PE5122323)

    When I click [Connect (Reset)] it pops up the same dialogue but now saying:
    "Can't communicate with the target processor! Please check your connections between the cable and the target and make sure the target has power"

    As the USB is integral with the DEMO board and it was working until the firmware got updated, I'm confident that there is no connection issue.


    • James,

      I'm sending a custom firmware for the embedded BDM multilink to you to try. Please unzip the file and place the firmware "usb20bdmens.590" into the PKGHCS08 STARTER folder. Then run PROGHCS08 and then click Connect. Hopefully at this point you will see the firmware update dialog appear.


  • OK, I tried that.

    The firmware update appears and then disappears.

    It says:
    Interface hardware detected with old firmware.
    Updating... (Please Wait)
    Original Firmware: 5.49
    Current Firmware: 5.83
    Update Firmware: 5.90

    Booting Multilink to original firmware (please wait) ...
    Then the last part changes to
    "Success. Version is 549."

    Then that window closes and a Warning box appears saying:
    "Cant find Update file. Firmware update failed. Retry?"

    If I click on Yes, I get the same dialogues.
    If I click on No a file chooser appears titled "Specify Programming Algorithm to Use!"

    Not sure what to do after this?

    Anyway, I tried to use CodeWarrior 6.3 again to see if the problem was magically fixed, but now I'm getting a licensing issue saying that I need to re-install the USB drivers. A balloon message popped up saying that the 30 day trial had expired. This only started happening after installing the PPC version of CodeWarrior.

    • Hi James,

      My thinking was that your DEMO board became corrupted with the firmware for the external USB-ML-12. I was trying to fix it by forcing an update to the correct firmware. What you should do now is delete the "usb20bdmens.590" that I sent you. There should be a file usb20bdmrefens.584 in your Codewarrior folder (just search for usb20bdmrefens.*) and then copy it over to where proghcs08.exe is. Then run
      PROGHCS08 again and hit connect. Hopefully, this time it will update properly and restore functionality.

      If it doesn't, you can use an external debugger like the USB-ML-12 or USB-ML-UNIVERSAL. If you're not in a rush, you can send the board back and we can take a closer look at it.


  • I don't have the .584 version, I have .572

    I tried copying that to the directory and running proghcs08_1k.exe but it doesn't try to load it. It just loses communication like before when I click "Connect"

    Is there any way to re-load the firmware using a second BDM pod?

    I find the DEMO9S08QG8 board very useful for reprogramming 9S08QG8 parts and want to be able to use it again.


    • James, 

      At this point I recommend you send the board to us and we will try to recover it for you. If you want to proceed, please fill in your information under My Account -> Edit My Contact, Shipping, Billing & Credit Card Information


  • It's unlikely to be cost effective unless you cover shipping. I can buy a new one for £33+VAT. I'm just worried that the programming software might corrupt the new one too.

    The firmware update utility REALLY ought to have OK/cancel buttons.


    • James,

      If you delete all the usb20bdmens.* and sb20bdmrefens.* files in the Codewarrior directory, it will stop any firmware updates from happening.


  • Hi, i have the same problem in my DEMO9S12XDT512, codewarrior update my board and now it not run.

    Hiwave show me USB1: USB-ML? (PE5025856) but it can not connected (find the BDM frequency)

    • Hi jawier,

      Please open a ticket under Support Requests -> Report a product bug or problem and one of our support engineers will try to assist you.


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement