Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Problem with Image Creation Utility from Jenkins-CI
Jeff H. Jul 15, 2015 at 11:14 AM (11:14 hours)
Staff: Huajun L.

  • I am trying to create a SAP image from a batch file that is launched from a Jenkins Continuous Integration server but the batch file hangs at your utility csapbdmcfz.exe (Task manager shows csapbdmcfz.exe in the process list but with no CPU activity).

    The full command line is:
    csapbdmcfz.exe ".\edin_image.cfg" imagefile ".\" imagecontent "eDIN-"

    The batch file runs correctly when launched from a standard command prompt without error.

    The machine running the batch file is set up as a Jenkins slave node using "Launch slave agents via Java Web Start" running via the Java JNLP-based agent "Jenkins Slave" configured as a Windows service (no GUI) on the slave machine.

    Is there any way to find out what your utility is doing as it does not generate any output to the standard console?
    Are there any conditions where your utility hangs (wait for input?) as opposed to aborting with an error?
    Any help greatly appreciated
    Many Thanks
    Jeff Heine
    Modelighting UK


  • Hi Jeff,

    In the same folder for csapbdmcfz.exe, do you have supporting DEF files such as CPR640L.DEF and so on?

    Would you please add a question mark (?) after csapbdmcfz.exe and try again? It will make the csapbdmcfz.exe window stay until you close it. Then please let me know if the task manager still shows it.


    csapbdmcfz.exe ? ".\edin_image.cfg" imagefile ".\" imagecontent "eDIN-"


  • Hi Huajun

    Sorry for the delay in replying. Problem solved! (more accurately disappeared)

    In performing the operations you requested and on further investigations I discovered that a previous build step was failing causing your app to generate a 'file not found' error. However today your app is working correctly under the slave agent as a windows service, and reports this error correctly without hanging. So the problem was with our system setup.

    I have now resolved these earlier build failures, and can confirm that my whole build operation including your app works just fine. Problem solved.

    Many thanks for your prompt help with this matter.

    • Hi Jeff,

      Glad to hear that the issue is resolved!

      Please feel free to contact us if you have any questions regarding our products!

      Best Regards

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement