Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink Universal FX stopped functioning: damaged?
Mark B. Jun 11, 2015 at 02:17 PM (14:17 hours)
Staff: Takao Y.

  • I've been trying to use a Multilink Universal FX that we've had for some time in a new system with CodeWarrior for MCUs.  I had things working earlier in the day, but not any more.  At this time neither LED comes on.  Both CodeWarrior and the P&E firmware updater can discover the device.  However, neither one can get much further.

    In CodeWarrior, P&E Connection Assistant displays "An error occurred while connecting to the interface hardware or target specified in the Launch Configuration Dialog..." and displays the connection parameters (with my Multilink shown in the connection information). (I know from another developer within our firm that he sees this message a lot using his non-FX Multilink; it seems a somewhat inconsistent interface.)

    And your firmware updater cannot complete an update of the ColdFire V234 firmware (using usbmlfx20cfens.706). It displays "Failed on verification of Logic Arrays Firmware update failed. Retry?" (I assume the first part should be two sentences, but that's what it says.)

    I had been able to perform both of these operations earlier in the day, but not now. The LEDs were coming on before too. My question is whether I have damaged something on the Multilink, or I've simply been Microsofted in some fashion I can't yet discern. Device Manager seems to be OK, with a "Jungo" folder containing "USB Multilink 2.0" and "WinDriver" entries (no alert icons) so I don't know what else to check.

    Please advise. Thank you!


  • Greetings,

    I am sorry that you are running into many issues with our product. I will do my best to answer your questions and solve your problems.

    First I want you to make sure you have the latest firmware on your multilink. Use the following utility to update your firmware:

    Second, make sure no other software is running that may be using the P&E interface and ports. For example, any P&E software or utilities, or another instance of a debug session. The multilink can only talk to one connection at a time.

    Lastly, update your Codewarrior to CW10.6.4. Have the latest version will solve many of the driver, firmware, and DLL issues you may run into with older version of the software. Newer hardware usually needs the latest and greatest support.

    Takao Yamada

  • Takao,

    I certainly thank you for the rapid response. Alas, this doesn't move things forward for me. I used your download link, but it provided the same updater version 5.17 as I had before, which produced the same failure result I mentioned, using the same image file usbmlfx20cfens.706. I tested this from a fresh Windows startup with nothing running beyond the usual Windows cluster of internal processes. Also, my CodeWarrior is already 10.6.4 build 150416 with no further updates available.

    Whatever else may be wrong, old software is NOT my problem...

  • Greetings,

    Which revision of the multilinks do you have? Both FX and non-FX.

    Within the debug configurations, try lowering the debug shift speed. Keeping lowering if you keep getting failure results until you reach the slowest speed.

    I also want you to create a new project for your chip and try debugging the default code with minimal changes in debug settings. See if you are seeing similar results. If the default project works, then there may have been a setting or code change that is causing odd behavior. (For example, not disabling the watchdog)

    Takao Yamada

  • The Multilink Universal FX exhibiting the failure is rev A.  The non-FX unit is in a different location and I don't have access to any information about it right now.

    I tried CodeWarrior using the slowest connection speed, option 31 (0.78MHz for FX) with no change.

    As to creating a new project... despite my doubts, I actually tried that, creating a default Coldfire 52254 project with no frills and trying to "Run" it, with the same P&E Connection Helper complaint. I don't believe the project is a factor here. I was having the problem I described simply trying to use CodeWarrior as a Flash programmer, not debugging or anything like that. I'm using a couple of known-good .s19 files from other offices within our company, and I can't program the device. I also tried a different (working, already programmed) target board with the same results. The first operation the programming process tries is failing: the console shows "cmdwin::fl::erase image" as the most recent operation, and things stop there whether I have the target board powered or not or the Multilink not even connected to the target. At no time does either LED light up.

    Given that these operations were working earlier in the day, I keep coming back to the question of whether my Multilink is damaged and in need of replacement.

  • Greetings,

    You have tried almost all of the tests I would run to find out if the multilink is damaged. One last thing I want you to try is using P&E software instead of using Codewarrior. This will remove many layers of possible problems. Install the following software and get a trial license:

    Look for the PROGCFZ software and try to connect to your device. If you ever get the prompt for an algorithm, then you are at least able to talk to your chip. Then look for the MCF52254 algorithm and see if you are able to run commands like erase module.

    If all fails then please go to Support page -> Support requests to create a ticket to request for an RMA ticket. Our support team will then send you instructions on how to send that unit to us correctly.

    Takao Yamada

  • Sorry, it took a while to get the program downloaded and installed and such.

    The PEMICRO Connection Manager came up and discovered the device. I clicked "Connect (Reset)". The window shows "Can't communicate with the target processor!"

    At no time did any LEDs come on. I was never asked about a programming algorithm.

    Is it time for the RMA process? Thanks!

  • Greetings,

    Are you using any USB hubs or usb isolators in your setup between the multilink and the computer? This could cause a struggle for current to reach the multilink. Try different USB ports and see if you can get the LEDs to show up.

    If there is no success, then yes you should go for RMA because it has many symptoms indicating damage.

    Takao Yamada

  • Takao,

    For the majority of the tests the Multilink was connected directly to a perfectly good USB3 port, although it had been on my USB2 hub when the problems first started.

    Thank you for your efforts; I'll be pursuing the repair path now.

  • One solution I've found is to go into Control Panel - Device Manager, under Jungo, and disable then enable the Cyclone/TraceLink device.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement