Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
CW Debug connection (was KDS 3.0.0 and Cyclone MAX problems )
Gary O. Jun 9, 2015 at 06:13 PM (18:13 hours)
Staff: Takao Y.

  • OK, I can reliably download every time via CW and Multilink.  Good.  But, it immediately gives me a "GDI Protocol fatal error / The Debugger is not connected to the PE device." dialog box.  Bad.

    PROGACMP still works perfectly, so it really is connected.

    I discovered that I had two copies of CW running; but closing both, then restarting one and only copy didn't have any effect on the GDI bug.

    The Debug Configurations window has changed a lot since the CW Help files for that screen were written. Do you have any more current information on their care and feeding?

    I have the Main tab beaten into submission. At least I think so.

    Is there anything special to know about the Debugger tab? In particular, the Download sub-tab has the Execute Tasks box checked by default, but there aren't any tasks listed in the box. Unchecking the box doesn't make any difference.

    All of the other tabs are at their default settings meaning mostly blank. Should any of them be changed?


    • Sorry, I forgot to say that I created a brand new project for this, as you suggested.

  • I also neglected to say that if I:

    - Start PROGACMP
    - Erase the flash.
    - Display memory to prove that it is blank.
    - Quit PROGACMP.
    - Start CW
    - Start a debug sequence to program the flash.
    - Let it run to the end (GDI fault message)
    - Restart PROGACMP.
    - Display memory

    The memory is identical to the first time. So, CW can program the flash; it just can't turn control over to the debugger.

  • Greetings,

    Thank you for the details and I will do my best to help you out.

    Could you detail me which chip you are programming? Which P&E multilink are you using and its revision?

    You should not have to make changes in main tab or startup tab to get things working. You just have to make some changes in the debugger tab to ensure your multilink is showing up correctly, the target selected is correct (yes even that number M12, M15, M50, etc postfix at the end). Then you should check if you need SWD protocol. Lastly, try lowering the debug shift frequency to see if that improves your setup.

    Takao Yamada

  • You're right about not having to make changes.  At a different company, I have the same version of CW with a Cyclone Pro, and it worked perfectly the first time.  I didn't even know these configuration options existed until this project. Be that as it may....

    The processor is the Freescale MK64FX512VLL12.

    Multilink Universal FX firmware version "usbmlfxufarmens.0927" or something like that. Or was until I updated it this morning. The updater doesn't say what version it is loading.

    PROGACMP version 5.21
    "P&E Interface detected - Flash version 9.33"

    The K64 doesn't seem to need SWD protocol. PROGACMP does not use it.

    PROGACMP uses a 2.5 MHz shift clock, so I settled on that. I tried 1.0 MHz, it didn't help.

    When I start the P&E firmware updater utility, it comes up for a Multilink Universal (not FX) and says that it can't find any device. When I change it to Multilink Universal FX, it finds the device immediately. Clearly they have different command interfaces.

    In CodeWarrior, I can download the program, and at the point where it cuts over to the debugger, I get a "GDI Protocol fatal error The debugger is not connected to the PE device" error message. This would suggest that somewhere there is something that expects a Multilink Universal and not a Multilink Universal FX device. The Run/Debug Configurations.../Target Settings/Connection tab says Multilink Universal FX in both of the list boxes. Are there any other places to set the device type?

    Gary Olmstead

  • Greetings,

    Firmware 9.33 is the latest and greatest so you should be set.

    Which version of Codewarrior are you using? You may need to update your codewarrior to CW10.6 update 4 to get the latest DLL's and firmwares to work nicely.

    There is no where else to specify your hardware interface. What you have told me should all work fine, but the Codewarrior version may be the only difference.

    Takao Yamada

  • I am using CW 10.6.4.  ...

    OK, thanks.

    Gary Olmstead

  • I need to break free and try a completely different approach.  

    I have a Tower with a K40 processor. Freescale says it uses open source JTAG; can I connect the Multilink Universal FX to it? If so, which connector should I use?

  • Greetings,

    Please read the user manual for your product:

    Read chapter 2.4, especially 2.4.2.

    Takao Yamada

  • OK, Thanks.


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement