Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cyclone PRO stops working after update Image Creation Utility
Thiago W. May 5, 2015 at 08:29 AM (08:29 hours)
Staff: Takao Y.

  • We use Cyclone PRO with 8.45-1.1 FPGA hardware version for manufacturer our products. Yesterday, we update our Windows version from XP to Windows 8, therefore we installed the last version of Cyclone MAX Image Creation Utility. This software (Image Creation Utility) updated our Cyclone PRO FPGA hardware version to 8.63-1.6 version, and now our factory and record process stopped because of #0000007 Error (Error entering in debug mode) .

    What is the difference between 8.45-1.1 and 8.63-1.6 version of firmware in Cyclone PRO and why We can't record more our products?

    Could you provide the 8.45-1.1 for downgrade ?

    PS.: We use Cyclone PRO to record Freescale MC9S08AC16 using BDM interface.

    Could you verify?


    • Hi,

      I am also having this problem. I have 2x Cylone Max programming boxes that have just updated to V7.85 . Both boxes are now giving Error 7 in every instance.

      I have product awaiting shipment to paying customers that can not be programmed!!!!!!!!!!!

      Urgent update on this situation is required!


      Kevin McDermott

      • Greetings,

        Read the rest of the forum. See if all of my suggestions work for you.

        Takao Yamada

  • PS.: The old version of Cyclone Image Creation Utility was 3.26, now we are using the last and not working more.

  • Greetings,

    Have you tried using the PROG software within the cyclone pro and see if you can connect to your 9S08AC16 device?

    We do not recommend downgrading a firmware. Updated firmwares have the latest bug fixes. Downgrading will void any warranties and if the FPGA version got upgraded from 1.1 to 1.6 then downgrading will brick your cyclone.

    Error 0007 indicates error entering debug mode to the chip. This could be several reasons most commonly due to wrong algorithm selected and the chip is not powered up. Is the cyclone pro suppose to power up your board? Di you make sure to enable cyclone power relays within your image configurations?

    Takao Yamada

    • Hi,

      We use External power supply with the jumper configuration below:

      : | | | :

      We don't use physical relays.

      And using the old firmware version of Cyclone PRO with old Image Creation Utility we have the configuration with the image below:

      Now using the last Cyclone PRO firmware and the last Cyclone Image Creation Utility doesn't work.

      Could you verify? Could you provide the old firmware version?

  • Greetings,

    Again, I cannot provide you the old firmware. It will only brick your cyclone, meaning it will be dead. The best solution is to solve the problem at hand instead of avoiding it.

    The image you sent me looks fine. If you create a new image with the new utility what does it look like? I want to quickly check to make sure everything there is fine.

    Another thing to try is using the new algorithms found in the algorithms folder of the new software install. We updated last in year 2013.

    Takao Yamada

    • Follow below, the screenshot of new Image Creation Utility and configuration of new version thats thats don't work:

      Could you see any difference between?

      If not, I can't see another solution insted do a downgrade.

      Is there any better way to see the details of #000007 error and this cause?

  • Greetings,

    The image you posted looks fine.

    There is no way for you to downgrade a cyclone pro if the FPGA version got upgraded. You would have to send the unit to us for reprogramming. This is why resolving this issue is easier than sending in the unit.

    Have you tried the PROG software I mentioned? This is the best way to debug this issue. See if the software can detect your hardware and load the algorithm. If it does not work in PROG, then something else is wrong and it is not the firmware.

    Takao Yamada

    • I'll do the tests that you mentionate and post the results soon.


  • Greetings,

    Any update on this?

    Takao Yamada

    • Hello,

      I didn't do the tests yet.

      • I tested, it's working. The topic can be closed.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement