Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
OpenSDA issue
James C. Apr 30, 2015 at 07:10 PM (19:10 hours)
Staff: Takao Y.

  • I am working with CodeWarrior and the OpenSDA option cannot be found, so I downloaded and installed (I thought) the most recent 11.7 drivers and also the Test Drivers app.   The Test Drivers app fails because it claims there is a mismatch.  Since this takes only text, and can't copy and paste the result, but it is saying that I have a version mismatch.  It is referencing C:\windows\system32\drivers\windrv6.sys which is version 11.03.  I'm not certain if this is the file that should be 11.7, or if there is another file that should be.




    Comments

    • I pasted the new .sys over the old and the error report went away when I ran test drivers.  Still, Codewarrior is not seeing the new instantiation of OpenSDA

  • Greetings,

    You may need to update the OpenSDA firmware. Please checkout our OpenSDA website for new firmwares and instructions on how to update it:
    http://www.pemicro.com/openSDA/


    Takao Yamada

  • This was up-to-date, but still no success.  Checking on the Freescale side why this would be happening

  • Greetings,

    I will assure you they will just tell you to ask P&E about this problem.

    I would advise reinstalling the drivers but ensure you have no P&E devices connected when installing. Also check device manager and make sure that you see:

    Jungo -> WinDriver -> Properties -> Version 11 or higher
    Jungo -> PEMicro OpenSDA Debug Driver
    Ports -> OpenSDA-CDC Serial Port

    If any of these are missing, then there may be a driver or firmware problem that still exists.

    Are you running a Virtual machine of some sort?


    Takao Yamada

  • Windriver was still out of date (11.3), and I am not seeing under Jungo the PEMicro OpenSDA Debug Driver, and currently do not see OpenSDA-CDC Serial Port.   THis is not a virtual machine.  I am simply running Win 7 64-bit

  • Greetings,

    So we know the issue is with drivers. Not with Codewarrior.

    First we need to fix WinDriver. You need to reinstall the PEDrivers 11.7 until this is fixed. Are you admin on your computer? This may prevent you from updating the drivers. Version 11.3 is out of date and you should be seeing 11.7.

    Only when WinDriver is fixed then we will look into your OpenSDA drivers and firmware.

    If you are still stuck, try on a different PC.


    Takao Yamada

  • Yes, I am admin.   I already updated the windriver to 11.7.0.0

  • Greetings,

    So when you right-click WinDriver -> properties do you see version 11.7?

    If so, now we need you to update the openSDA bootloader. If you downloaded the openSDA firmware, you would see a bootloader update app. Read the "BOOTUPDATEAPP_release_notes.txt" to learn how to update.

    Then read the Updating the OpenSDA Firmware.pdf to learn how to update the debug app for your board. You have not indicated which board you are using so I cannot pinpoint the one you need.

    Lastly, check device manager and make sure the 2 opensDA firmwares show up.


    Takao Yamada

  • Yes, version 11.7 is showing up.

    Something seems hosed on the board as it is not behaving the way it used to. I can enter bootloader mode, it shows up as the G Drive (Bootloader), and when I click on SDA_INFO it reports that the bootloader version is at 1.09 and the microboot kernel is at 1.05. Since I should be operating with bootloader version 1.11, I drag over the Bootloader .SDA which is in a separate zipped file on your site, indicating the correct version to update. However, when I unplug and then plug, nothing happens on the board. The LED never comes on (unlike when I entered bootloader mode) and if I entered bootloader mode again, I confirm that no update has taken place.

  • Greetings,

    Any update on this? Were you able to resolve this issue? Was your board damaged or bricked?


    Takao Yamada

  • No, I was able to recover it.   It appears the the board was missing the debug driver (even though I had dragged this driver to the boards dedicated drive a number of times.  I went to the device manager, located the complaint regarding the missing driver, right clicked and updated.

  • Greetings,

    Wonderful, I am glad you were able to recover the board. Are you now able to now flash and debug the board as you once were?


    Takao Yamada

  • For some reason, the simple program provided (simply flashing an LED) was not working.  The LED would turn on but not flash in a version of "Hello World".  I was thinking there was an issue with the timer or the interrupt, but going over with an FAE could not find anything wrong.  We switched over to the Multilink System ( I believe that's what it is called) and programmed it in this manner.  Same program but it worked.  So I bypassed openSDA.  It appears to program the board - I no longer get the notice that the driver is missing - and I jump to a start address, but when I execute a run, the program didn't do as I expected.   I haven't spent a ton of time looking into why the OpenSDA method failed.  Clearly something is not quite right.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement