Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Unable to get multilink to start up
anthony h. Apr 17, 2015 at 04:58 AM (04:58 hours)
Staff: Takao Y.

  • Hi Everyone,
    I hope someone can offer me some advise on starting communiations between a USB coldfire multilink and a board.
    What I've done.

    1. Installed software ware and drivers
    2. Plugged in Coldfire multilink, blue and orange lamps come on.
    3 Start up P&E software.Connection manager pops up
    4 This shows the interface UDB multilink.... Port USB1 USB-ML_CF Rev C, Coldfire processor auto detected.
    5 I click "Connect(Reset)" button.
    6 Status window shows
    "USB-ML-CF detected - Flash Version 5.54"
    "Device Debug Module : Revision A"
    "Device Detected : Generic 52XX"
    "Debugger retrying force to background mode"

    It does this 3 times then the connection manager pops up again with a message on top
    "can't communicate with target processor! Please check connections between the cable and the target and make sure target has power"

    I can see the target has power as blue and orange led's on coldfire multilink are on,there is no cable, the multilink plugs straight into the port.

    can anone offer any any advise please?


  • Should add using win XP, used the driver check software and everything seems good

  • Greetings,

    What chip are you working on?

    Have you tried lowering the debug shift frequency in the connection manager, before you click on "connect"?

    Takao Yamada

  • Thanks I got it to work, what I've found is if my USB is connect when I power up it will not work. If I connect after power up it detects the use and works. I've tried this multiple times and get the same result. Must be something to do with my windows xp ?

  • Greetings,

    I am glad you were able to get it working. However there should be no difference of when to connect the P&E interface. If this is a problem you want help solving, please create a support request ticket on our support page and detail us on how you are powering your P&E interface, your board, and if there are any special circuitry involved like adapters, reset drivers, etc.

    Takao Yamada

  • Greetings,

    Just so I understand this issue better, for the HCS08SH chip are you connecting all 4 pins of the BDM: Pin 1 (BKGD), pin 2 (GND), pin 4 (RESET), and pin 6 (VDD)?

    Also, is the chip pre-programmed or a blank chip?

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

  • I too have the same problem. I am working on MPC 5554 with Codewarrior IDE,The target power not connected error is appearing.what could be the problem. I am using multilink probe

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement