Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink Universal is not programming blank Kinetis devices
frederico m. Apr 6, 2015 at 08:34 AM (08:34 hours)
Staff: Takao Y.

  • Hello everyone,

    I'm able to program a custom board with Freescale MKL05Z32. We develop a new prototype and I soldered the chip manually. Unfortunately I'm not able to program a blank microcontroller in this board.

    Things to be considered:
    1) I'm shure Multilink Rev. B is ok because I can debug other (the same part number) microcontrollers.

    2)Multilink is connected to the custom board via ribbon cable. I tested continuity with a multimeter. It seems to be ok.

    3)I'm using a 32kHz crystal.

    4)I tried to programm with and without 10k resistor and 100nF capacitor (all combinations) in the reset pin.

    5)Measuring reset pin shows that microcontroller is reseting. There are 2us pulses every 34us (29,4kHz).

    6)When I try to debug or erase whole Flash Code Warrior 10.6 opens the P&E Connection Assistent box saying that "an error ocurred while connecting to the interface hardware or target specified in the Lauch Configuration Dialog".

    7)I try to do the steps described in this article but it didn't solve the problem. Other article were also tried without sucess.

    8)After validating and testing the prototype, we will need a programmer for production. Actually we have Elnec but it's necessary to buy some credits for programming every single chip. We have only the Multilink for development. Is Cyclone the a good tool for this purpose?




  • Greetings,

    Thank you for the detailed information.

    The one clue that is worrying is the reset line. You indicated pulses every 34 us. Is this happening for a long period of time? If so, this is a sign of a watchdog. Check your schematic for any system bus chip or external hardware watchdog that may be preventing you to access the chip.

    Takao Yamada

  • Thanks for replying Takao Yamada,

    yes, if I turn the chip on I measure pulses on reset pin. It's happening indefinitely. Measuring reset pin while trying to debug I saw that reset pin is always on. Testing the same Multilink in other application I saw the reset pin going down, as expected.

    If I connect the Multilink ribbon cable, reset pin goes high. If I remove ribbon cable reset pin keeps high.

    I searched on web and find a tool called Kinetis_Recovery_Utility. I saw that it can halt the processor. Then I could make a programming. But it would not be a solution for mass production, that will be necessary in some weeks.

    Hardware is as simple as possible. It is feed normally and I put external pullups only in reset and NMI_b pin.

    Is this commum with these programmer and blank devices?


  • Greetings,

    I am glad the Kinetis Recovery utility worked for you. This is a sign that RESET is definitely your problem. This happens if RESET is not connected to your P&E hardware or RESET is disabled on your chip.

    1) Is RESET connected to the P&E multilink? Is it connected to any external reset driver? Or is it a direct connection from multilink to chip (not counting the pull-up resistor or cap to ground).

    2) When the chip is blank, there is no code to run when powered up so the chip is constantly in RESET. The pulses you see are from the internal watchdog. This is expected behavior. Only when the chip is halted can the P&E multilink enter debug mode and flash program. But as long as RESET line is connected and not being impeded by external signals, then the P&E tool will be able to reset the chip and enter debug mode with no problems.

    3) P&E's cyclone is a great tool for production. The multilink relies on a computer and a software to run, and a user with knowledge of how to use these tools. With the cyclone, an engineer can load an image to flash program and on the production line the user simply presses the START button with no learning curve of how to use the tools. No computer needed on the production line and flash programming will be much faster with no USB protocol bottle-neck. But if programming is not working with multilink without the use of the kinetis recovery utility, then even the cyclone will not help you. We need to resolve this RESET issue first.

    Takao Yamada

  • Hello Takao Yamada,

    Yes, I've read about this behaviour when chip is blank.

    Today I made new tests starting from the beginning. As the board does not have a header, only isles for programming, it was necessary to solder the ribbon cable wires directly to this isles. I saw that the pin 4 (GND) was soldered in a wrong isle, not a ground. Correcting this mistake solved the problem, mass erase and flash program could be done perfectly.
    I was trying to program 2 boards. One of them is ok, but the other I still can't program. But I think we can consider problem solved, probably the second chip is damaged because Multilink can't connect.

    Many thanks for supporting,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement