Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
firmware update failed on Universal FX with result=$7151
Tian M. Apr 3, 2015 at 05:02 AM (05:02 hours)
Staff: Gerardo R.

  • Hi, 
    I used 'P&E Firmware Updater Utility' ver1.09 to update Uniersal FX from S08 to Kineti. Firmware file selection is 'automatic'. After touch the button 'Update Firmware', a warning jump out with 'Flash Erase Failed. Result= $7151........'

    Any setting should be done?

    thx




    Comments

  • I also installed the multilink_universal_install.exe as website. Still failed.

  • What is the hardware revision on the Multilink FX?

    • Rev.B

    • Hi, 
      Any update for the issue?
      Thx

  • Can you try updating your Multilink firmware update software?
    http://www.pemicro.com/downloads/download_file.cfm?download_id=346

    • Hi, Gerardo
      I downloaded the SW and tried. The failure is as before, 'Flash Erase Failed. Result= $7151........'

      I asked my coleagues to test. Rev.A of Multilink Universal FX with the same steps. They are ok on Rev.A. And I also tried to ask my coleagues to update Rev.B Multilink Universal FX, all are failed with the same result, 'Flash Erase Failed. Result= $7151........'

      So, whether it means that Rev.B has HW bugs?

      BR
      Oliver

  • Greetings,

    Is this issue resolved? Any update on this?


    Takao Yamada

  • Hi, Takao-san
    After I used 'Firmware Updater Utility' of 'P&E Multilink Universal FX', the firmware could be changed.

    When I programmed QSPI flash with Multilink Universal FX on MPC5645s, it failed. While used the same SW and algorithms through Multilink Universal, it could be ok.

    My customer ordered 10 sets 'P&E Multilink Universal FX' for MPC5645s development. Now, it can't programmed QSPI flash with FX. Please help to find out solution.

    Thanks
    Oliver

  • Are you certain that the firmware updater utility is selecting the correct Multilink to update? Are there any other Multilinks plugged into the computer? I'm asking because this error message suggests that the software is trying to update a new Multilink with firmware for the older Multilinks.

    • Hi, Gerardo
      I used 'Firmware Updater Utility' to update FX firmware to MPC5xxx successfully. Only one Multilink was plugged into computer.

      Maybe the topic of this issue should be changed to 'QSPI flash programming with Multilink UniversalFX'. (with algorithms of Spansion_S25FL064P_2x32x2048k_QuadSPI_MPC5645S_parallel_Rev2.PCP)

      I changed to Multilink Universal with the same operation and success. Whether you can try at your site?

      I made the snapshots for both. But I can't upload to the forum.

      If possible, you can share your email address and I can share the snapshots to you.

      Regards
      Oliver

      • Greetings,

        You are better off creating a support request ticket by going to Support Page -> Support Requests. There, you can post images and files (please zip them up).

        We can continue our discussion on the new forum post you created.


        Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement