Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Undetected. Disconnect/Connect USB cable. Click refresh list
Dan B. Jan 22, 2015 at 07:34 PM (19:34 hours)
Staff: Takao Y.

  • Hi,
    I've been using Windows 7 (64) and Code Warrior 10.6 to program FRDM-KL05Z board. - No Problem downloading and running programs.
    Today I received some FRDM-KL25Z boards and I created a suitable project. All was going well until I tried to set up the run configuration. I got the "Undetected. Disconnect/Connect USB cable. Click refresh list" message.
    I did that but no change.
    So I read and followed FAQ #29 - still no change
    So I read and did it again - still no change
    I downloaded Driver test and ran it with the following result.

    ERROR!!! C:\Windows\system32\drivers\libusb0.sys not found
    ERROR!!! C:\Windows\syswow64\libusb0.dll not found
    (detected) C:\windows\system32\drivers\windrvr6.sys (Version 11.01)
    (detected) C:\Windows\syswow64\peusba05.dll ()
    (detected) C:\Windows\syswow64\peusba06.dll (Version 11.01)
    (detected) C:\Windows\syswow64\peusbb05.dll (Version 10.01)
    (detected) C:\Windows\syswow64\peusbb06.dll (Version 11.01)
    (detected) C:\Windows\syswow64\peusbmgr.dll ()

    So there is a problem but I don't know how to fix it.
    Can anyone help me please?

    Thanks
    Dan




    Comments

    • Hi,
      I used MSD-DEBUG-FRDM-KL25Z_Pemicro_v114.SDA to update the board and when I unplugged and replugged it, the system searched windows update for some drivers, found them and loaded them.
      I have the board working now however, DriverTest result is still the same.
      I'm not sure if this is a problem or not...

      Dan

  • Greetings,

    I would still suggest reinstalling your drivers to make sure that "error" in your driver test is gone. You do not want to get more problems in the future.

    Here is the link to the drivers download. Make sure to disconnect all P&E related hardware from you computer before and during the install. Then reconnect them afterwards and it should all be cleared up:

    http://www.pemicro.com/downloads/download_file.cfm?download_id=301


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

    • Hi,

      I am using TWR-S12G128. I am also facing same error and I am unable to flash the controller. Even i tried with latest driver suggested in the previous reply, But still same error.

      Please help me how to resolve this error. I tried to program the board from different PC's, it didn't help.

      Thanks in advance.
      Durga Prasad

      • Hi,

        I could able to resolve this issue by reinstalling the code warrior along with the drivers. Before installing newly follow the below steps.

        1. Uninstall the existing code warrior tool.
        2. Uninstall all the P&E drivers.
        3. Delete the P&E and Freesclae folders from the C disk.
        4. Delete all temp data. (press windows button and search %temp% --> show the temp dir)
        5. restart the pc.
        6. Install the code warrior IDE. and should be compatiblel with the controller which you are going to flash.
        7. Install the latest drivers from P&E website (www.pemicro.com)

        Once this procedure is success, then code warrior will be able to identify the port.

        Tested with TWR-S12G128 evaluation board.

        Thanks

        Durga Prasad

  • Greetings,

    Thank you Durga for reporting back with your results. I do not think it is necessary for step 3 to delete all folders but I guess that is last resort if you just cannot get the problem resolved.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement