Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Failed to program MCF52259 with universal multilink: flash device ID command failed
Joel Y. Dec 12, 2014 at 02:41 PM (14:41 hours)
Staff: Takao Y.

  • Hi,

    I'm trying to program the MCF52259 using universal multilink with no success. I tried both on window xp using CW 7.1 and window 7 using CW 10.3 . Before i was able to do it using usb coldfire multilink. I have also try to update the universel multilink firmware version 5.17, the firmware has been successfully uploaded but i failed to program my chip. then i also tried the version 1.09,but it didn't work. Can you please tell me what i'm doing wrong.

    Best regards,
    Joel Yonli




    Comments

  • Greetings,

    My experience with MCF52259 (which is almost weekly for the last 3 years) is that you need to drop the debug shift frequency to a much lower value to ensure a stable communication. Especially if you have the Universal Multilink FX, then the multilink is much too fast compared to the chip's internal frequency. A normal multilink at option 0 is 1Mhz, while the FX is at 25Mhz!!

    Try lowering the shift frequency one by one and until you reach a stable communication. If you reach the last option and still have issues, then it may not be something else wrong.

    Do you happen to have any custom ribbon cables, adapters, reset circuitry, external watchdog, system bus chip, or other unique hardware?


    Takao Yamada

    • Hi Takao, 

      Thank for your reply. I tried what you said and the code seems to move forward, but then still show the same error with the following:
      "Data is not in flash range". I have a unique hardware.

      Thank you.

  • Greetings,

    1) Want to tell me what unique hardware you have? This may change the type of settings you may need to set.

    2) The error you told me indicates you are programming outside of the flash location. Do this, create a brand new project in CW10.3 for your chip and try programming the flash without making any changes to the code. See if you are able to start a flash program with no issues. The default project should not have issues with data out of flash range.

    3) Within Codewarrior 10.3, are you using the flash programmer tool, or are you trying to start a debug session?


    Takao Yamada

  • Takao, 

    1) What do you mean exactly by unique hardware ?
    2)I tried what you said and you are right. The default project as no issue regarding the data out of range, but it show " An invalid preference was passed to GDI protocol adapter".
    3) I use both. I tried first with flash programmer, then with debug.
    4) I tried also using CW 7.1 it didn't work and there is no debug shift frequency there.

    Joel.

  • Greetings,

    1) I asked a question earlier: Do you happen to have any custom ribbon cables, adapters, reset circuitry, external watchdog, system bus chip, or other unique hardware? This is what a unique hardware means. Do you have anything between the P&E hardware and the chip that may interfere with the communication.

    2) Not sure what this invalid preference is, but you should compare between your project and default and find out what settings and files are different and experiment which ones will fix your problem.

    3) Try the debugger one. Debugger is implemented by P&E and that is the only version I can help you with. Target task flash programmer is implemented by Freescale so I cannot help you there.

    4) There actually is a shift frequency but it is hidden. You need to go to your project settings and look at "remote debugging". There you will find the "Edit connection" button and find the "Speed" option. This is the shift frequency and put the value 15 or 20.


    Takao Yamada

  • Takao,

    1) I have no hardware between them. Just some pull up on BKPT,DSCLK, DSI, and DSO.
    2) I will let you know.
    3) But about the debugger one, it said that for code greater than 64K, i need to
    configure the debug by adding the debug file in Debugger/Download/execute Tasks with First and Subsequent checked. So when i run the debug i got an Alert that tell me that the debug will execute target task.

    But when i uncheck execute Tasks, The code seems to be partially downloaded(reset button on debug interface is blinking).
    4) I changed the frequency on CW 7.1 from 10 to 31 it didn't work still showing error getting flash ID failed.

    Joel.

  • Greetings,

    Any progress on this? If the default project still works, if I were you I would start from there and step-by-step add more code to it. I cannot help you with the 64k code-size limitation but I can help you debug any problems with getting your P&E hardware to work.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement