Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone Max - Cannot Program in Standalone Mode
Venkat R. Dec 12, 2014 at 01:24 AM (01:24 hours)
Staff: Takao Y.

  • Hi,

    We purchased a Cyclone Max last week with the intention of using it to program a MPC5601D processor (Qorivva 5xxx) .

    I am able to program this in interactive mode using the Interactive Mode. See screenshot of the settings here: http://imgur.com/A4bwCDf


    I created an image using the Image Creation Utility: http://imgur.com/h30Azma and connected to the Cyclone. I am able to see the SAP image.

    However, when I try to launch it using the "Start" button, I get an error 0000007 displayed on the Cyclone LCD. The sap_launch utility also has error : http://imgur.com/IekMnSH


    I am not sure what I am doing wrong.

    Regards,
    Venkat




    Comments

  • Greetings,

    Error $0007 indicates problems communicating to the chip. This could be either hardware or software settings problem. Error $000A within sap_launch indicates error writing to memory. At least this means the cyclone can communicate to your target.

    Things to check:
    1) Are you replicating the exact setup that worked in PROG interactive? Same commands, same algorithm, same settings, same cyclone, and same target?

    2) After getting these errors, are you able to switch back to interactive and still be successful in flash programming?

    3) Are you using any unique hardware between your target and the cyclone that I should know about? For example any external watchdog, reset circuitry, custom adapter, custom ribbon cable, any system bus chips?

    I have not heard a case where switching between standalone and PROG interactive gives different results. But if this was the case, it is a timing issue because interactive is obviously slower than an automated script running commands one after another.

    A heads up: Recently I optimized the flash programming of the MPC5601D for standalone that cuts down the programming time by half! It is a change in the Cyclone Max firmware and I will let you know when that gets released.


    Takao Yamada

  • 1) I am using the exact same commands, same algorithm. 
    2) Yes, I can switch to PPC_NEXUS_CMAX(From memory, may be incorrect) and program it right away
    3) We are using a custom ribbon cable as we have to probe the JTAG connection.

    Would you suggest adding delays in between steps?

    Regards,
    Venkat

  • Greetings,

    With any extra hardware, you add delays to the communication. You may need to drop the debug shift frequency in your standalone image. If you are already probing the JTAG connection, you should check to make sure there are no long rise times and whether the reset signal needs more time to toggle. Possibly add 100ms reset delay into your standalone image.


    Takao Yamada

  • I've tried it at the lowest speed, and with a reset delay and still does not work. 

    See : http://imgur.com/QiH8PyQ

    I was wrong earlier, the error on the Cyclone Screen is 0x0000000A

    Regards,
    Venkat

  • Greetings,

    Let us try a different set of commands in your standalone list. Try just CM, SS, and EM. Are you able to communicate to the chip and erase?

    Once you get erase working fine, then try PM command. And when that is working then try VM command. I just want to see where it is actually failing because writing to memory can fail either at erasing or at programming.


    Takao Yamada

  • I talked to someone else in support earlier, and they made me just load the CM file in the SAP image, and I still have the same error 0000000A. 

    I was able to successfully talk to it using the CProg that I am temporarily using as a workaround. Here is the log from this..

    CYCLONE detected - Flash Version 7.84
    CMD>RE
    Initializing. -Target has been RESET and is active.
    CMD>CM C:\PEMicro\PROGPPCNEXUS\Algorithms\Freescale_MPC5601D_1x32x32k_CFlash.PCP
    Initializing. -Initialized.
    ;version 1.11, 02/04/2014, Copyright P&E Microcomputer Systems, www.pemicro.com [560x_128k_cflash]
    ;device Freescale, MPC5601D, 1x32x32k, desc=CFlash
    ;begin_cs device=$00000000, length=$00020000, ram=$40000000
    Loading programming algorithm ... Done.
    CMD>SS C:\Flash\boot_90-10124-01.s19
    CMD>EN
    Blank Checking ...
    Module word not erased at address $00000000 word is $015A.
    Erasing. -Module has been erased.
    CMD>PM
    Checking range of S records. -Checked.
    Programming. Address $ Processing Object File Data ... 00000000000010000000200000003000000050000000700000007E30000081D0000082D0000083F0000084700000F000. Programmed.
    CMD>SS C:\Flash\app_90-10125-02.s19
    CMD>PM
    Checking range of S records. -Checked.
    Programming. Address $ Processing Object File Data ... 000100000001100000012000000130000001500000017000000190000001B0000001D0000001D3700001D8900001FFF0. Programmed.

    All programming steps completed.

  • Greetings,

    Currently the customer is trying to send me a board for evaluation of this issue.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement