Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Summary for USB Adapter Use Under VMWare?
John P. Oct 30, 2014 at 08:20 PM (20:20 hours)
Staff: Takao Y.

  • Has anyone come across a good summary of how to make P&E Micro's various USB adapters work properly for both flashing and debugging under VMWare?  I have three different adapters (USB MultiLink ColdFire rev C.1, USB MultiLink Universal Rev. B, and a USB BDM MultiLink for RS08/HCS08 rev. C.) and all three are painful to use under VMWare (and, I presume, VirtualBox).  When these do work, the best I can do is use them to flash the target.  I've long since lost the ability to do any debugging with them.

    My host machine is a Windows 7 64-bit, so the "classic" tools from Freescale don't work reliably there. My virtual machine is a Windows Vista 32-bit which at one time was my host machine.

    I'm not the only person who has run into this. A moment's of Googling shows plenty of people have had the same problem. And there is lots of advice, from move the clock jumper on the MultiLink ColdFire (tried that), to the FAQ here that says to revert back to the Windows 98/ME drivers (tried that).

    So yes, I could detail the problem, but it would be the same details that plenty of other people have provided before-- with the usual variations. Maybe someone had the problem with Windows XP, not Windows Vista. Or maybe the host was Windows 8. Or maybe... you get the idea.

    What seems obvious is that regardless of the various configuration details, there is a fundamental problem here, and it's that problem, once solved, that will make all the slight permutations on machine/VM configuration work.

    This is incredibly frustrating. I used to have tools that worked, then new drivers came alone and tools sometimes worked, and now newer drivers and things aren't working much at all. Could someone either provide set of instructions to make both flashing and debugging work, or at the very least provide a clear description of what the problem(s) are?


  • Greetings,

    I use VMWare with our tools and Freescale's Codewarrior on a daily basis.

    If you are trying to use Freescale's classic Codewarrior, you must understand that those IDE's came out before 64-bit machines and Windows 7 came out. So there are going to be difficulties trying to make it support an operating system that never existed. We do have unofficial patches that help resolve this issue so that you can run classic Codewarrior in Windows 7/8/8.1 64bit. My plan was to announce and provide these patches onto our website early next week, but if you would like them now you can let me know and I can send you via your P&E account. But a more updated version will come out soon.

    If you are using P&E software, any software built before year 2010 will not work in 64-bit machines. Even if you have the latest drivers, that only allows the P&E hardware to be detected by the machine but the software lacks the support. You must upgrade your software.

    If you plan on using VMware, the key tip is to make sure you install the P&E drivers on both the host and client operating systems. The P&E hardware must be detected by the host machine first, then on the VMware you can "attach" the USB device onto the client operating system. You can set your VMware to automatically attach your hardware once you got it working manually.

    I hope that explains many of the problems that you may face trying to use the latest operating systems. Like any software you may use on a daily basis, many have 32-bit or 64-bit versions and you need to get the correct one for the operating system you use.

    Takao Yamada

  • As I previously stated, I am using the "classic" CodeWarrior IDEs under VMware where the guest operating system is 32-bit.  So the fact the host is 64-bit is irrelevant as the IDE isn't being run there.  

    Yes, I would like whatever patches you have immediately as the inability to do symbolic debugging means I have little more than the system's LEDs to debug with. I believe I first reported this problem at least a year ago, and I've seen other reports in various forums going back to 2011.

    I will install the drivers on the host operating system as well. That's yet another piece of new information that I haven't come across.

  • Greetings,

    I have sent you an email with the new patch I just tested yesterday. Hopefully it will work in your set up as well. Let me know if it works or it does not so I know if it is ready for public release.

    Takao Yamada

  • Greetings,

    Did the patch work?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement