Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
How do I attach USB_ML-CF in Virtual XP on Win 7 64-bit machine
Mike H. Jul 2, 2014 at 10:31 AM (10:31 hours)
Staff: Takao Y.

  • I was recently "upgraded" to a WIN7 64-bit machine from a 32-bit version, which worked fine. I had to install Virtual XP to run CodeWarrior, but I can't get the USB-ML-CF to attach in virtual XP and if I try to install the P&E driver in Virtual XP, it just hangs up. Does anyone know how to make this work? I'm using CodeWarrior V7.1 and have a USB-ML-CF Rev C. Thanks!




    Comments

  • Greetings,

    On virtual machines, how USB drivers works is that it first needs to be recognized on the host PC and then it gets forwarded to the virtual machine. So, you need to install the drivers on the Win 7 machine and make sure it shows up there before attempting to getting it to work on the Virtual XP.

    We do not guarantee this will work. I have had some customers say it worked, some say it did not. It seems to differ between the USB host controller on the computer's motherboard. Good luck!


    Takao Yamada

    • I installed the driver in Win 7 and the device shows up in my Device Manager, so it is recognized in Win 7. I'm not sure what to do now. Surely there must be a way to use the debugger using CodeWarrior under Win 7 64-bit. Thanks in advance for any tips.

  • Here's some additional information I left out. In Virtual XP, the USB-ML-CF shows up, but after I select ATTACH, it disappears. Hopefully that helps.

  • Greetings,

    Check within the virtual XP machine's device manager and see if under "Jungo" you see both "WinDriver" and "USB Multilink 2.0" showing up after attaching it into your virtual machine.

    Another thing you should know is that Codewarrior 7.1 is not supported in Windows 7 or 64-bit machines. Even though it sits in an XP virtual machine, the drivers involved to talk to the multilink is still 64-bit since the actual Intel chip you are using is 64-bit. Therefore, you may need an unofficial patch from us to fix this issue for ColdFire. Please create a support request ticket via our support page requesting for this ColdFire patch for Coldfire and we will give you a zip file.

    Another thing to note, you really do not have to put your Codewarrior into a virtual machine. Many people have copied the Codewarrior into their Win 7 64-bit system and have simply used our patch to get their P&E hardware working. Just copy (do not move) the whole Codewarrior directory from your virtual machine onto your host PC and see if it works. This way you no longer have to worry about running your virtual OS and attaching hardware to it.


    Takao Yamada

  • That's awesome. Thank you!

  • Greetings,

    If anyone is looking for the patch fix, please checkout this FAQ:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement