Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
PROG08SZ.EXE in VirtualBox Won't Program
Michael R. May 28, 2014 at 10:37 PM (22:37 hours)
Staff: Takao Y.

  • Hello,

    I have been using this program for years in slackware under wine. I recently moved to new PC hardware and slackware 14.1 and decided to run a copy of XP in VirtualBox instead of wine.

    In this environment, PROG08SZ.EXE comes up just fine and finds my "Class 3 - Direct serial to target w/MON08 serial port circuitry built in." I am programming an 908QT4 and the programming algorithm loads fine and the software makes contact with the device. I am able to erase the device just fine. However, when I try to program the device with my S19 file, I get:

    Checking range of S records. Checked.
    Programming Address EE20. Error during programming.

    Sometimes the error is at EE10.

    I am using a real serial port, not a USB adapter. The programming board works fine using a different computer running XP native.

    How can I debug this problems?



  • Greetings,

    I just recently rebuilt this software to support the latest operating systems and drivers. See if this improves your setup problem you were having with a virtual machine:

    Let me know if you still run into issues.

    Takao Yamada

    • Hello Takao,

      Thank you for your response and a new copy of PROG08SZ.EXE. However, the problem remains exactly the same.

      Can you recommend any way to debug the issue?


  • Greetings,

    Unfortunately, we never tested out a virtualbox setup on Linux with this software and using the serial port for programming. If the software works fine in normal XP machine, then there must be something wrong within Linux or the virtual box. I doubt it is a problem of the software.

    My suggestion is to monitor and test your serial port using some external tools and creating a test to see if the serial data is getting through correctly. It will be too difficult trying to debug using PROG software since you will not know the signals without knowing the proprietary data and API being sent.

    Takao Yamada

    • Hello Takao,

      Thank you for your reply.

      Well, some of what you said is exactly my point. The serial port works for other applications, so I need to know something about your protocol to debug it. Some considerations are:

      1) Do you depend on any flow control? If so, which?

      2) Do you depend on two way alternate communication? In other words, if things are buffered by linux or virtualbox, does this cause timing errors?

      3) Do you do any timing or waits based on processor spins? Another factor here is that my target machine is double the speed of any prior machines.

      4) Is there any multi core dependency? I've never run on more than a single core before, and this machine has 6 cores.

      I am very suspicious of timing in your protocol since erase and the various memory inspections or deposits work fine. Only, when I program the module do I get the error.

      Any further suggestions would be appreciated.


  • Takao,

    Thank you for your help. I do believe that I have identified the problem, but I don't have enough hardware to confirm my conclusion.

    On my 3.5 GHz AMD machine with 6 cores, PROG08SZ.EXE gets the same error identified in my original post using either virtualbox or wine for my Windows environment under LINUX. I limited the environment to a single processor with the same result. To eliminate the serial port hardware as the issue, I ran the experiment again with a USB to serial port adapter. Once again, I had the same issues.

    I moved PROG08SZ.EXE to a 1.8 GHz Intel single core machine. The programmer works just fine under virtualbox on this LINUX host environment.

    In all cases under virtualbox, the same copy of Windows XP was used. Wine emulates Windows without using any Microsoft code.

    From this I conclude that either there is an AMD vs. Intel issue, or a timing situation based on CPU speed. In my experience there have been no problems with PROG08SZ.EXE on AMD hardware, but the problem first showed up on the faster machine. Therefore, I conclude that somewhere in the PROG08SZ.EXE there is a CPU speed dependency when connecting with a serial port.


  • Greetings,

    Sorry that I have not replied back to you in a while. We also do not have the resources to test this theory out whether it is AMD vs Intel. It is most likely a timing situation based on the CPU speed.

    This software has been stable and no longer will be updated due to the chip architecture of HC08 being old and further development is discontinued. Therefore, the best solution I can give you is to purchase one of our MON08 Multilinks:

    The Multilink on Windows 7 and modern computers does work and we have tested this.

    Takao Yamada

  • Hello, I have a similar problem.

    In my laptop I have Ubuntu 14.04 LTS, and using WIN XP virtual box.

    In This environment, PROG08SZ.EXE comes up just fine and finds my "Class 3 - Direct serial to target w / MON08 serial port circuitry built in."

    When loading the programming algorithm is very slow, as happens when you load the file .S19.

    I use a USB-serial converter "Prolific PL2303" probe with another USB-Serial "FTDI FT232" converter and gets slower.

    My laptop is a Dell, Intel Core Duo 1.66Ghz processor, 2GB RAM.

    I can do to speed up programming?


    • Greetings,

      I am glad your setup works, as previous customers has had troubles.

      You indicated the loading of the algorithm is very slow. How slow are you talking? What is this compared to? Have you used PROG08SZ with serial on an XP machine before without any converters and virtual machine as a comparison?

      Using serial is already pretty slow in Win XP and adding a layer of USB to serial conversions and a virtual machine is only going to make it slower.

      Takao Yamada

      • Miguel & Takao,

        I'm the original poster.

        My problem is a little different than Miguel's since in my case I am unable to program at all. So far what I have found is that any multi processor machine fails for me. I have kept around an old single processor machine to program the microprocessor.

        The assembler and simulator work just fine in the multiprocessor environment, and that's what I use for development.

        I use the single processor machine to program using both the RS232 and a USB converter. Both program equally well and both are as fast as you'd expect with 9600 baud.

        I am using VirtualBox and MSW XP in both environments.


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement