Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
MPC5605B shrink version progppc error: error in ONCE status register during instruction execution
Rolf H. May 27, 2014 at 11:15 AM (11:15 hours)
Staff: Takao Y.

  • Hi there,
    while flashing with progppcnexus using the upcoming freescale MPC5605B (shrink, copper bonding, new die, new fab etc.) I'm getting the error: error in ONCE status register during instruction execution. Previous versions of the controller worked fine for the last few years.

    I think I had same issue with a new version of the HC12s some years ago, but I can't remember how I got that one sorted back then.

    Any ideas how to solve this?

    Thanks a million!


  • Greetings,

    A few questions for you:

    1) Do you get this error before or after selecting your algorithm of choice?

    2) Is the chip's part number actually MPC5605BK, or is it MPC5605B? There is a difference and there's a different algorithm for the BK version.

    3) Have you tried lowering the shift frequency. This error you get is usually communication problem and if you have the frequency too fast, then you could be having some connection issues.

    Takao Yamada

  • Hi there,
    as to 1) the error occurs when I try to connect to the chip and repeats after choosing an algorithm again
    2) sorry, the actual chip is the SPC5606BMLQ6 as regards to an applicable algorithm we already got an upgrade for the Freescale_MPC5605B (works with the previous chips version) algorithm from PE which is versioned 1.11
    3)I'm aware of that and tried various different frequencies to no avail
    Thanks for your help!

  • Hi again,
    just an update, in the meantime I tried to flash the device with the current starter/demo version and at least flashin the dflash works fine, albeit the cflash can't be flashed due to codesize restrictions. Sounds to me an update is due. Cheers!

  • Greetings,

    That was going to be my next suggestion was trying to use our latest software and demo to see if this was a software issue and not hardware.

    I am glad you went ahead and tried it out and hopefully solved your problem.

    Do you have any other questions or concerns?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement