Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
How do you connect USB Mutilink Universal to MC9S08AW
David H. May 22, 2014 at 12:01 PM (12:01 hours)
Staff: Takao Y.

  • I have gone over the Technical Summary for the Multilink and I don't understand how to connect it to the MC9S08AW. Did I make a mistake in buying the for the S08AW? The schematic doesn't show any "BGND" or "TVCC" where Multilink calls for them.

    Please advise



  • Greetings,

    The connection you want to use with the multilink universal is the 6-pin ribbon cable for the MC9S08AW on port C (BDM).

    Your board requires a 6-pin header (2x3) that pulls the signals for BKGD (pin 1), RESET (pin 4), VDD (pin 6), and GND (pin 2).

    Some customers have created their own ribbon cables and adapters to work with their hardware setup. Our suggestion for customization is to use shielded cables and to at least have BKGD, VDD, and GND connected. Reset is not absolutely necessary, but note that to enter background mode the chip must go through a power-on-reset and you would need to manually reset the chip if the RESET is not connected.

    Takao Yamada

    • Since the pin "BGND" isn't shown on the diagram of the 44 pin LQFP (still looking at the data sheet for the MC9S08AW32) do you know which pin on the microchip it is?

      Sorry, thought it would be more straight forward than this.

      Will the Multilink connect with SPI?


  • Greetings,

    There is no BGND. It is the BKGD signal on pin 36 of the 44-pin LQFP.
    Currently we do not have any SPI support for our tools.

    Takao Yamada

  • Takao,

    :) Thanks for pointing out pin 36, must not have turned the sheet around.



    • Lots of thanks, got it connected now.

  • Great!

    I am glad things are working out for you.

    Do you have any other questions or concerns? Otherwise I will mark this forum thread as resolved.

    Takao Yamada

    • Well, actually that problem is resolved. But I have another two.

      First, do you know of a board I could program MC9S08AW32 on?

      I have got to get these puppies programmed to see if the code works, and then make some mods to the code. Guess that would be my first question.

      Secondly, I am getting the round robin problem of "An error occured while connecting to the interface hardware or target specified in the launch
      configuration Dialog. For this launch, you may retry/re-specify the connection with the following parameters:
      USB Multilink -USB Port
      UMulilink Universal Rev B on USB1 (Name=PE5658649)"

      2.   "Launching LC for Simple Flash (2) has encountered a problem. Would you like to export diagnostic information and send it to Freescale?
      HC/RS/S12Z/ GDI Protocol Adapter: Can't connect The Debugger can not connect to the PE device
      Details:" (details same as above line)

      I did all the suggestions related to BGND, VDD, RESET, and GND. The signal "BGND" does seem to transision nicely.

      Do you have any suggestions as how to solve this problem?

      Oh,yeh, I am new to Freescale and this is my first time using this programmer, so I won't be insulted by any simple suggestions either.

      Thanks very much.


  • Greetings,

    So you do not have a board but just chips to program? I suggest asking Freescale support about this question. They used to make socket adapter boards where you could put chips into sockets and program them with ease. And yes, our tools work great with these adapters. We have some here and I use them often. But I am not sure if they still sell it.

    The problem you see with error connecting to your target is due to either RESET or BKGD signal is not responding correctly. Do you have an oscilloscope to monitor some of these signals? If so, I would check to make sure that when you click "connect" in the software that you see RESET and BKGD both go to 0V and then RESET goes back high to 3/5V to ensure the chip is entering background mode correctly. If you see the RESET or BKGD signals not having clean and fast rise times, then I would suggest adding 4.7k pull-up resistors on that signal.

    If you do not have a scope, then I would make sure that when you do get that warning message in the software that BKGD is actually being held low at 0V. Then go ahead and power reset your board and see if BKGD is still held low. If not, that means somehow the connection from the P&E interface to the board/chip was lost.

    Takao Yamada

    • Mr. Yamada,

      Thank you for the useful information and the quick reply.

      We do have a very good scope and I had monitored the BKGD signal but wasn't sure what was "normal"

      You have cleared that up. I'll be working on what you have suggested.

      Yes, we have the chip on-board but we want to reprogram code on-board to see if we have all the org. code and verify we are able to program it, and then flash the new code on.

      What I have done is jumper,ed the necessary pins on the micro MC9S08AW (pin 36)
      and RESET (pin e) and attached them to the programming cable in the proper pins.

      Do you see (other that your suggested pull-ups) any problems with that?

      Thank you again,


  • Ok, Codewarrior gives me this error. "Error setting debug context for run configuration Active Debug Context"

    I have both leds blue and yellow on, the signal on both pins went from low to high and stayed high. I am considering the pull down resistor but I think I need to solve the error setting first, any suggestions?

    We are using the MC9S08AW32CFGER.

  • I think I cleared that issue up, but when I tried to flash

    I got this error.

    Target MCU is not responding.

    Reset power both lines went low, stayed low.

    Tried to program again and reset got some kind of signal on it for a short while and then I got the not connected error.

    Didn't have time to sinc the scope to the signal to see what it was.

    Any suggestions?



  • Greetings,

    Again, all of these errors are due to the BKGD and RESET lines not functioning correctly.

    Try adding a 4.7k pull-up resistor (not pull down) on BKGd and RESET. See if that improves your situation. If it does not, then you do need to use a scope to figure out what is going on. The P&E hardware normally does not need any complicated circuitry to get this working. Usually just a straight reliable connection. If your cable coming out of your P&E interface is longer than a foot, I would suggest shielding your cable.

    Takao Yamada

  • Ok, both BKGD and RESET lines low.
    I have the error "The target MCU is not responding, turn MCU power on"
    Turn power on click ok on power cycle dialog
    BKGD goes high
    I get two signals on both BKGD and RESET, pulses on RESET.
    then I get the P&E Multilink USB Port connection assistant error.
    Quick set of pulses then back to "Power Cycle Dialog" error.
    I am watching with scope
    I put 4.7k pull-up resistor on both lines as suggested.
    BKGD stays high, RESET goes back to low.
    What would you suggest?


  • Greetings,

    It really should be a simple connection where 4 pins connect directly to your chip. The pull-up resistor is the only modification that I ask customers to try to generate a better signal. But if you are having odd BKGD and RESET signals, then there is something else connected or a loss of communication somehow.

    My last few suggestions are to make sure your multilink has the correct firmware by using the firmware update utility found on the CD that came with your multilink. Is there anything you have not told me, like do you have an external watchdog, another reset circuitry, or other modifications?

    If not, then I have exhausted all suggestions.

    Takao Yamada

  • Woops, well I made a mistake. I admit when I make mistakes, I am so sorry.

    Seems that the BGND signal, I connected it incorrectly. Wrong pin.

    Corrected that problem. Really sorry about that, I had the diagram turned wrong in relationship to pin one.

    Yes, I did try it again with these corrections and got a different error. Could you please make a suggestion on what I might do to correct this problem?

    The other errors are gone and the new error is: Target Task Error
    Error executing task number 2 (name of my flash)
    Error: Connect Failed. Codewarrior Plugin can not get the Remote Connection collection object. Please make sure CodeWarrior is installed Correctly.

    Thank you,


  • Greetings,

    I am glad you are back on track. I was worried you would get lost.

    Target task is Freescale's implementation of flash programming found within Codewarrior. Unfortunately, P&E has no expertise on this matter. You should try Freescale's forum or contact their technical support for getting your target task set up correctly. I advise, however, to read Codewarrior's Help guides about target task before asking them questions that can already be answered.

    If you were debugging a project within Codewarrior, then that is P&E's implementation of flash programming and that I could help you with. But target task is different.

    Takao Yamada

  • My friend I can not thank you enough.

    I have learned a-lot. I believe the error is caused by the plug-in time line being reached. I loaded CodeWarrior early on and it was much later before we started on this project. So I think it timed out.

    Anyhow, again you are correct, I do thank you for all your help.

    Sleep well tonight, for you have helped someone.


  • Greetings,

    I take joy in helping others and I am glad you learned a lot. It reminds me the first time I started working at P&E and I had similar problems and questions as well.

    Do you have any other questions or concerns? If not, then I can mark this thread as resolved.

    Takao Yamada

    • So is the recommendation now to use 4.7K pull-ups and not 10K?  I am having this problem also on many boards and am seeing about 3.1V on the BKGD and RESET lines.

      • Greetings,

        We usually recommend 4.7 to 10K ohm resistors as pull-up. The most popular reason for the BKGD and RESET lines to be at 3V instead when VDD is 5V is when users do not connect the VDD to the P&E interface. Although the P&E interface may not provide power, it still needs the VDD connection as a reference voltage.

        Takao Yamada

        • The VDD pin is referenced to 5V.  Any other ideas?
          Is this a Windows 8.1 (64-bit) driver issue?

  • Greetings,

    Are you sure there are no modifications done on the multilink, or possibly it is damaged? Pop open the multilink's case and see if there are any damages.

    The drivers are only to allow your computer to recognize the P&E hardware. As long as your multilink is showing up in the device manager, then you should not have to worry about drivers.

    Make sure you have the correct firmware for you multilink. Use the firmware update utility that come with the multilink universal CD and make sure you have the correct firmware the chip architecture you are trying to program.

    Lost your CD? Then download the utility here:

    Takao Yamada

  • I may have posted on another thread, but we were able to fix the problem by shortening the target cable to 4 inches.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement