Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Device Secure message
vinod k. Mar 6, 2014 at 05:58 AM (05:58 hours)
Staff: Takao Y.

  • Hello,
    I am trying to program a custom board (KL04) via the Multilink.It worked fine, but then it shows the "Device is secure.Erase to unsecure". I keep pressing Yes. AFter doing this twice the "Multilink" not connected is shown. There was another board that was doing the same. But, its now, surprisingly working,except this 1 board.
    I tried the Processor halt utility. Still no luck.Uninstalled/installed PE drivers. No luck.
    Also, no where in the code have I modified that register (FTFA_FOPT or any such dangerous registers:) . Infact CODE WARRIOR warns you if you make any changes to such registers.)

    Kindly give me some suggestions.



  • Hi Vinod,

    What software are you using to program your custom board (KL04) via the Multilink? Is it PROGACMP? If yes, what version of PROGACMP are you using?

    Are you enabling low power mode on the KL04?

    • You know, I am suddenly getting this same problem!

      I have a KL15 that I have been programming just fine, now I am getting this "Device is secure. Erase to unsecure" dialog box. At least I am consistently getting the error on 4 different Multilink devices, talking to 4 different boards.

      I am using Keil UV4. It is configured to program using the PEMicro Debugger. The window that opens during programming is labeled: CPROGACMP Programmer for Freescale - Version

      I am trying to do the programming automatically, and the various pop-up windows are un-needed or, with this device secure box, disruptive.

      If I could get around using UVision, I'd be happy. Can I execute CPROGACMP in command-line mode? How about calling it directly, rather than going through UVision?

      As for low power modes, no clue.


      • An update on my situation... I have given up on using the Keil uVision as the interface for programming my devices. I could not get enough control of what it was doing.

        Instead, I am using PROGACMP and no longer getting the "Device is secure" complaint/dialog box. Well, that is unless I include the SD command in the .cfg file.

        It is not a silver bullet, some other problems have arisen. I can no longer program all 4 of my boards at the same time.


  • Greetings,

    Has this issue been resolved? Do you have any other questions or concerns?

    Takao Yamada

  • Hi

    I have similar problem with my board. uC is kinetis: MK10DX256VLK7. I use multilink universal and IAR envirnoment.
    I simply try flash with standard build what I use every day nad get this error:
    "Device is secure. Erase to unsecure?"
    But of course erase is not possible.
    I do not know what happend, I have not touche any secure bits. The same build is used on other boards and works perfectly.

    1. Is any way to resolve this problem?
    2. Is it possible that something is wrong physically? e.g. connection.


  • I have check, and mass erase is enabled in my hex:
    under address 0x40C i 0x31 and 0x40D is 0x30.
    Hex was not secured. However I do not know how to erase device.
    Is any script what may help with erase device or maybe it is other problem (e.g.) connection to uC?


  • Greetings,

    The "Device is secure" message is misleading. What is happening is the P&E interface cannot communicate to the chip. That happens when the chip is detectable but the interface could not enter background mode. Therefore the interface thinks the device is secured. But this problem could happen if communication is bad.

    Things to look for:

    1) Do you have custom ribbon cables, adapters, reset circuitry, or external watchdog? If so, you should monitor the JTAG/SWD signals and make sure there are no significant delays, odd chip resets, or noise.

    2) Try reducing the communication speeds. There should be a debug shift frequency option before connecting to your chip. Lower the speed for better communication.

    Takao Yamada

  • Greetings,

    Do you have any other questions or concerns?

    Takao Yamada

  • Hi

    no, thank you.
    seems something is wrong with uC.

    Best Regards

  • Hi all 

    I am facing same issue Device is secure ; erase to unsecure and by clicking yes not able to download the code .
    MAMAP staus is 36

    can any body suggest how excatly move on the things . I am using P&E programmer and debugger and freescale K60 is the controller .
    When check on the scope for reset pin , controller is continously resetting

  • Greetings,

    Continuous resetting would mean a watchdog is in play. Our flash programming algorithms disable the watchdog for you so it is not the internal watchdog. You must have an external watchdog on your board. Check your schematic on the chip's reset line and see what components and circuitry is connected.

    Just a note, the message that the device is secure is actually not the right error message. It means the P&E interface was able to detect your chip but had troubles communicating to it. So it thinks the chip must be secured, but if could be other things like an external watchdog that prevents external tools from accessing the chip, etc.

    Takao Yamada

  • hi takao

    thanks for the reply !!! actually on the RESET line I have only 10K pull up resistor .


  • Greetings,

    There would be no reason for resetting to be toggling continuously other than a watchdog. The internal watchdog will only interrupt if the chip is running your code and you did not handle the watchdog interrupts correctly. Once you attach a P&E hardware it will load the P&E algorithm and disable the internal watchdog. Are you sure you have no system bus chip, or competing circuitry that may disturb communication?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement