Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Problem Programming MPC5554
Mark W. migrated on Dec 31, 2013 at 11:00 AM
No staff assigned yet

  • I have a USB-ML-PPCNexus interface for programming aboard with an MPC5554. 

    The processor is the only device in the JTAG chain.

    Initially I used the eSys Flasher utility V1.3 from Freescale. With this configuration I am able to read memory successfully until I attempt to reprogram at which point the program gets stuck in the "Erase" cycle. I do not think ths starts. After which I need to perform a H/W reset to read memory successfully.

    I have downloaded the P&E starter pack and attempted to use this. This fails when trying to load the flashing algorithm to 300000.
    With this software I have tried slowing down the interface, but same result.

    I can successfully program our card with the Green Hills SuperTrace Probe through their AdaMulti debugger - but this needs a network license and won't work on customer sites.

    I am able to use this successfully program with both the eSys Flasher/P&E USB Multilink and Green Hills Probe/debugger on the Freescale Eval board JTAG implementation looks the same.

    Any thoughts?


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement