Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
CPROGCFV1 crashes
David K. migrated on Dec 31, 2013 at 11:00 AM
No staff assigned yet

  • I'm getting started with programmer scripts, the goal being to load serial numbers onto some dev boards with built-in embedded USB multilink.

    When I try to run cprogcfv1.exe from the command line, the status window appears, says "Windows NT Detected" and "Copyright 2008 P&E Microsystems," and then it promptly crashes.

    It does not crash if I do not specify a script file. If I pass the "?" argument, it stays open and tells me there was no script specified. If I give it an empty file, it does crash.

    Is there an update since 2008 that I need? I just downloaded this.




    Comments

  • QUOTE (Potatoswatter @ Mar 4 2011, 02:59 PM) [legacy comment]
    I'm getting started with programmer scripts, the goal being to load serial numbers onto some dev boards with built-in embedded USB multilink.

    When I try to run cprogcfv1.exe from the command line, the status window appears, says "Windows NT Detected" and "Copyright 2008 P&E Microsystems," and then it promptly crashes.

    It does not crash if I do not specify a script file. If I pass the "?" argument, it stays open and tells me there was no script specified. If I give it an empty file, it does crash.

    Is there an update since 2008 that I need? I just downloaded this.


    Hi,

    When did you purchase the software? If you just downloaded this recently, then you have the latest version.

    What devices are you trying to program?

    Please enter the commands exactly as follows from your commandline:

    C:\pemicro\progcfv1>CPROGCFV1.exe ? config.cfg Interface=usbmultilink port=usb1

    Please attach your programming script so I can check it.

    Best Regards,
    Johnny
    P&E Technical Support




  • QUOTE (Johnny @ Mar 4 2011, 03:32 PM) [legacy comment]
    Hi,

    When did you purchase the software? If you just downloaded this recently, then you have the latest version.

    What devices are you trying to program?

    Please enter the commands exactly as follows from your commandline:

    C:\pemicro\progcfv1>CPROGCFV1.exe ? config.cfg Interface=usbmultilink port=usb1

    Please attach your programming script so I can check it.

    Best Regards,
    Johnny
    P&E Technical Support


    Yes, I downloaded it just this afternoon. It is the trial version; I did not purchase anything. (And I don't need 16 KB.)

    The board is a DEMOJM.

    That command line crashes just like any other. Even an empty script crashes, although no script at all produces an error message.

    For what it's worth, the script I'd like to run is attached.

    Thank you for the help!

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement