Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
error126
John N. migrated on Dec 31, 2013 at 11:00 AM
No staff assigned yet

  • Can anybody tell me how to get rid of this error. I suspect that I do not have the correct software loaded. I have Windows 7 64 bit OS with a demo9s12xdt512 board.

    Thanks




    Comments

  • Hi Nuss580903,

    Could you provide the name of the software and the version that is causing this error?

    Best regards,
    Edison

  • QUOTE (Nuss580903 @ Nov 11 2010, 04:14 AM) [legacy comment]
    Can anybody tell me how to get rid of this error. I suspect that I do not have the correct software loaded. I have Windows 7 64 bit OS with a demo9s12xdt512 board.

    Thanks



    Hi, have you solved this problem?
    I have the same problem, Running Windows 7 64-bit

    I am using Freescale Codewarrior, and the message appear when i press debug, and "True-Time Simulator & Real-Time Debugger" opens.

    The following output can be seen in the windows with title "Command":
    Loading Target ...
    IO registers loaded for MC9S12P96 from C:\Program Files (x86)\Freescale\CWS12v5.1\prog\REG\MCU02EB.REG
    Error 126 while loading library : C:\Program Files (x86)\Freescale\CWS12v5.1\prog\PEOSBDMV1.DLL
    Error 126 while loading library : PEOSBDMV1.DLL
    Unable to load OSBDMDRIVER : PEOSBDMV1.DLL
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83






  • Hello Cbratli,

    Which version of Codewarrior are you using? Is it CW5.0 or CW5.1?

    Which hardware interface are you trying to use to connect to your Freescale device?

    Which Freescale device are you using?

    Are you working with a custom board or an evaluation board designed by Freescale?

    Best Regards,
    Zahar
    P&E

    QUOTE (cbratli @ Dec 15 2010, 05:12 AM) [legacy comment]
    Hi, have you solved this problem?
    I have the same problem, Running Windows 7 64-bit

    I am using Freescale Codewarrior, and the message appear when i press debug, and "True-Time Simulator & Real-Time Debugger" opens.

    The following output can be seen in the windows with title "Command":
    Loading Target ...
    IO registers loaded for MC9S12P96 from C:\Program Files (x86)\Freescale\CWS12v5.1\prog\REG\MCU02EB.REG
    Error 126 while loading library : C:\Program Files (x86)\Freescale\CWS12v5.1\prog\PEOSBDMV1.DLL
    Error 126 while loading library : PEOSBDMV1.DLL
    Unable to load OSBDMDRIVER : PEOSBDMV1.DLL
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83



  • I am using CW5.1 (CodeWarrior Development Studio for the S12(X) Version 5.1, build 10221) (CodeWarrior IDE version 5.9.0 Build 5294)

    In CW, Connection Manager, I Select "USB Multilink, Embedded Multilink, or Embedded OSBDM"
    Target CPU Information: "HC12/HCS12 - Autodectect Device Type"

    When pressing "connect", I get the errormessage in the command windows. It does not matter if the debugger is connected or not.

    Selected device is(Selected from HC12MultilinkCyclonePro->Set Derivative): MC9S12P96

    I have the: USB BDM Multilink for RS08-HCS08 HC(S)12(X) - ColdFire® V1, PART# USB-ML-12E

    I am working on a custom board, but the errormessages appears even though no hardware is connected.

    It looks like I can load the program fine (No error messages, and the program works), but how can I be sure everything is OK when it has problems loading the DLL's?

    Best Regards
    Cbratli

    QUOTE (Zahar Raskin @ Dec 27 2010, 05:22 PM) [legacy comment]
    Hello Cbratli,

    Which version of Codewarrior are you using? Is it CW5.0 or CW5.1?

    Which hardware interface are you trying to use to connect to your Freescale device?

    Which Freescale device are you using?

    Are you working with a custom board or an evaluation board designed by Freescale?

    Best Regards,
    Zahar
    P&E



  • QUOTE (cbratli @ Dec 15 2010, 03:12 AM) [legacy comment]
    Hi, have you solved this problem?
    I have the same problem, Running Windows 7 64-bit

    I am using Freescale Codewarrior, and the message appear when i press debug, and "True-Time Simulator & Real-Time Debugger" opens.

    The following output can be seen in the windows with title "Command":
    Loading Target ...
    IO registers loaded for MC9S12P96 from C:\Program Files (x86)\Freescale\CWS12v5.1\prog\REG\MCU02EB.REG
    Error 126 while loading library : C:\Program Files (x86)\Freescale\CWS12v5.1\prog\PEOSBDMV1.DLL
    Error 126 while loading library : PEOSBDMV1.DLL
    Unable to load OSBDMDRIVER : PEOSBDMV1.DLL
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83
    USB HCS08/HCS12 MULTILINK detected - Flash Version 5.83


    Has this problem ever been solved? I know that one person just used a different .ini file but not what made the difference. I'm using 5.1, WIN-7 64 bit, 9S12DP512, and a MULTILINK that arrived from P&E last week.

    John

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement