Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Not able to connect MPC5566 using PROGPPCNEXUS
Jay S. Jan 9, 2020 at 06:19 AM (06:19 hours)
Staff: Takao Y.

  • I'm trying to connect MPC5566 using PROGPPCNEXUS starter addition but not able to connect. 

    I'm getting below message in status window

    Device IDCODE is %00000009
    Device ID revision is $00000000

    Please help why i'm not able to connect ?

    https://i.postimg.cc/G9wqykvg/pe.jpg




    Comments

  • Greetings,

    Did you try lowering debug shift frequency and adding 200ms delay after reset before connecting to your device?


    Takao

    • Yes i have tried with lower speed and adding 100ms, 500ms and 1000ms reset time.

      With 1000ms sometimes i got IDCODE $00000029

  • Greetings,

    How long is the ribbon cable between the target and the multilink/Cyclone?

    Are you using any custom ribbon cables, adapters, or other unique hardware?

    Could you monitor the reset line with an oscilloscope to see if it is toggling often? If so, you may have a watchdog problem.


    Takao

    • How long is the ribbon cable between the target and the multilink/Cyclone?
      --> I'm using standard cable which comes with Multilink FX.

      Are you using any custom ribbon cables, adapters, or other unique hardware?
      --> using standard cable.

      Could you monitor the reset line with an oscilloscope to see if it is toggling often? If so, you may have a watchdog problem.
      --> In circuit there is not external watchdog is used so no change of reset while multilink is communicating.


      Is it possible that the chip is got locked and JTAG is disable?
      but here I'm getting Device IDCODE and Revision that means JTAG is working hope so...

      In locked state can I get IDCODE and Revision?

  • I have tried with other hardware and got the IDCODE and Revision 00000000.

    In JTAG header I have connected below pins

    1 - TDI
    2 - TDO
    5 - TCK
    9 - /RESET
    13 - /RDY
    2 - GND
    10 - TMS
    14 - JCOMP

    other pins left open

    What's the problem?

  • Greetings,

    You can still get the ID code even if the chip is censored. But based on your screenshots you posted on the other forum thread, you are able to enter debug and see the memory in ICD PPCNEXUS, although most of it is XX. So I do not think it is censored. Within ICD PPCNEXUS, could you follow Edison's suggestion of setting up the init script to mpc55xx so that RAM is initialized correctly? This may give us more insight.


    Takao

    • I successfully got connected after few trails and shield open connections.

      Now I’m not able to load .ppc file

      Please see error

      https://i.postimg.cc/Kzb3ghpk/ppcerror.jpg

      As per editions suggest, I have followed below step

      1) Connect with ICDPPCNEXUS
      2) In the menu bar, go to "Configuration -> Automated Script Options"
      3) Check the box that reads "Run Script File after the Debugger RESETS the MCU:" and specify the "mpc5500_any_init.mac" file
      4) Click OK and type "reset" into the Status window
      5) Try looking at RAM (address 0x4000_0000) and modify the contents.


      Please see result

      https://i.postimg.cc/FHKfjxxp/error.jpg

      In status window you can see i have tried to write bit not succeed. Got XX data at 0x40000000 address

      What is the issue now?

      • Please give solution. I have just purchase debugger and I’m facing problem.

  • Greetings,

    Are you able to modify the registers within ICDPPCNEXUS? If you cannot change registers or RAM, then I do not think you have a good connection to the target board.

    You will need to get an oscilloscope and see if you are seeing noisy connections on TDI, TDO, TCK.


    Takao

  • Chip is MPC5566. 

    Complete part no is MPC5566MZP132

  • Greetings,

    Ignore my previous reply for part number, I have updated my questions.


    Takao

  • I’m not able to change register value. I have also tried to modified RAM content but it shows XX.

    Debug speed is lowest (31).

    Using standard ribbon cable connected to board via one small 2 inch length custom ribbon cable straight connection.

    Did I received faulty debugger?

  • Greetings,

    No, I do not think the debugger is faulty, yet. We test our hardware before selling and you only bought it recently.

    I am reviewing your connections you mentioned before and you did not mention VDD/VCC connection. Why is this omitted? Without it you will face lots of problems. It is the reference voltage for all the signals.


    Takao

  • I have connected VCC reference later but result is same.

    I have connected all 14 connection.

  • Greetings,

    You need an oscilloscope. That is the only way forward. As long as you have all 14 pins connected and using the latest software and hardware from us this setup is supposed to work out-of-the-box. So something else is giving you problems. If the device was censored/locked, then within ICD you would not be getting as far as you had.

    On the scope you are looking for clean crisp rising edges and no curved edges on rising or falling edge. Otherwise you have a cap connected on that line that is causing delays.


    Takao

    • Rising and falling edge seems to be fine. not able to check TCK signal because when i connect probe to TCK connection break and it won't even connect.

      Please see waveform of TDI and TDO
      CH-1 is TDO and CH2 is TDI.

      https://ibb.co/YdCqycM

      Setup:
      https://ibb.co/MMkxJ56

      • basically this is a automotive ECU which i'm trying to read for tuning purpose. I don't think any issue in hardware because ecu is produce in high volume and programming done in production. 

        If any component cause any issue then they have also face issue during production so don't think hardware issue.

  • Greetings,

    My concern is not the board itself or your software setup. My concern is the connection you have between the multilink and the board. I want you to make sure you can read on the oscilloscope the signals on TCK, RESET, and TMS as well. You can skip RDY and JCOMP. Also make sure your GND and VCC connections are solid.

    From experience, the RESET line is what causes this issue you are seeing. After entering debug the RESET line would continue toggling and cuts off communication as you start to load the algorithm to the part. Hence why it fails to load. If this device is indeed produced in high volume, then I expect this board to have an external watchdog or system bus chip to prevent others from entering debug on this board.


    Takao

    • I have monitor all signals TCK, TMS, TDI, TDO and RESET on oscilloscope. signals are pretty steady no issue.

      There is no watchdog in circuit I have monitor RESET signal and it is not toggling so there is no chance of connection loss.

  • Greetings,

    It is supposed to be plug and play.
    You have two options:
    1) Open a support ticket on our support page and send us schematics of the board for further analysis
    AND/OR
    2) Send the board to us for analysis


    Takao

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement