Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
progACMP: algorithm requires version 1.17 - currently running 1.16
Matthew M. Jun 18, 2014 at 08:39 AM (08:39 hours)
Staff: Takao Y.

  • When I try to use progACMP to program a new K64 design (freescale_k64fn1m0m12_1x32x256k_pflash.arp), I get the warning that I need 1.17 or later.  It asks if I wish to attempt to load the algorithm anyway.  If I say yes, I get the message:

    Loading programming algorithm ... Error loading .ARP file : D:\Projects\ADM Firmware\freescale_k64fn1m0m12_1x32x256k_pflash.arp at address 20000000

    So is this the type of error that I could expect to fix with the 1.17 version of progACMP - and, if so, how do I update my version?

    Thanks,
    Matt




    Comments

  • Greetings,

    Yes this is the type of error you will see. Certain algorithms have new features that the PROG software may not support yet. This is why you need the newer version and it warns you about it.

    To update any of our software, you should first find out the order/invoice of the software purchase. Our software upgrade policy is that if the software was purchased within the last year, you get a free upgrade. If within 2 years, you get a 50% discount to upgrade. Anything time outside of 2 years will involve purchasing a new license at full price.

    If you believe you qualify for any discounts, please create a support request and let us know your order/invoice number and we will confirm if you do indeed qualify. Then we can proceed to get you that discount when you go purchase the upgrade.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement