Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
GDB PEMicro Interface Debugging failed
Anthony H. Dec 24, 2019 at 01:30 PM (13:30 hours)
Staff: Gilbert Y.

  • Maybe somebody can help me with this,

    I have been successful in debugging the frdm-kl25z board before, but unable to debug it now. I am using Eclipse 2019-09, when trying to debug, I get this error message (from the log) "Plug-in com.pemicro.core was unable to load class com.pemicro.corePlugin" and "Plugin com.pemicro.core was unable to load class

    Thanks in advance


    • Hi Anthony,

      You are using a vanilla Eclipse IDE, not NXP's MCUXpresso? Can you tell me what version of our plugin you installed/have installed?

      Gilbert Y.

      • Hi Gilbert, thank you for replying!. I am using the vanilla Eclipse.  I am not a home right, not exactly sure the version of pemicro plug in.  But I think it is version 4.4.1

      • Hi Gilbert, below are the plugin and version in vanilla Eclipse

        Plugin Name Version
        P&E Core Plugin 1.2.0
        GNU ARM Interface Debugging Support -
        PEmicro ARM Device Expansion Plugin -

        Anthony H.

        • Thank you for providing the version numbers. How exactly are you debugging your ARM projects in Eclipse? Are you using GNU MCU Eclipse? (

          • Hi Gilbert, yes I am using GNU MCU Eclipse.

          • Hi Gilbert, one of the error message is 
            "Plug-in com.pemicro.core was unable to load com.pemicro.corePlugin.StartService"

            Anthony H.

            • Hi Anthony,

              This version of Eclipse is not an IDE we officially support, but I saw that GNU MCU Eclipse is soon to be officially part of the Eclipse CDT package so I will be investigating this issue. Please allow a few days for me to get back to you regarding our findings with the holiday this week.

            • Hello again Anthony,

              I tested out the KL25 example project with our MultiLInk Universal Rev D and did not seem to have any issues within GNU MCU Eclipse. I did have to make a change to the path of the GDB Client in my debugger settings, but other than that, I left everything as default.

              Have you uninstalled and reinstalled the plugin to see if that changes anything?

              • Hi Gilbert, 
                I did try to uninstall and install. I did not use the MultiLink Universal. I am debugging the kl25z board with opensda and pemicro. It is just pc, micro usb cable and kl25z board. I don't need any other adapter. I have been able to debug with this setup before. I don't know what did to break it. I see that the folder com.pemicro.corePlugin is empty. There is no StartService in the folder. Thanks for your help again.

                Anthony H.

                • Very odd. How have you been installing and uninstalling the plugin? I installed the plugin by adding the updatesite to the "Install New Software..." window with the link The com.pemicro.corePlugin folder does appear to be populated through this method.

                  • Yes, I use the same site in the Install New Software, but does not show any packages because I had the "Don't show installed packages" checkbox checked.  If I uncheck it, then it will show, but when I tried to install it again, it failed because it was already installed.  I think uninstall and reinstall using the plugin tab in eclipse.

                    Anthony Heak

                    • Please try the following method and let me know if you are still experiencing issues:

                      1. Go to Help -> About Eclipse IDE
                      2. Click on "Installation Details"
                      3. In the "Installed Software" tab, filter your software with "pemicro" and uninstall all software related to PEmicro from eclipse. Restart Eclipse as necessary.
                      4. Go to Help -> Install New Software. Use the update site to fetch plugin software.
                      5. Install "GNU ARM PEmicro Interface Debugging Support" if you just need NXP devices or "PEmicro ARM Device Expansion Plugin" if you want all supported devices. Restart as necessary.
                      6. Test debugging. At this point, I did have an issue with the GDB client, but I may have improperly set up some paths.

                      • Hi Gilbert,
                        I tried the steps that you listed, but still couldn't debug.
                        I delete the old eclipse, install a new version of eclipse and install gnu mcu plugin, pemicro plugin. Now the able to debug again, thank you!

                        Anthony H.

                        • I am glad to hear that you were able to resolve your issue. Feel free to reach out again to us on the forums, as well as our other contact methods for more immediate needs.

                          Thank you,
                          Gilbert Y.

  • Ok, I will try the suggestions when I get home and let you know.  Thanks again for your help.

    Anthony H.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement