Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Can't connect to peserv after Win10 update
Russell S. Oct 9, 2019 at 03:12 PM (15:12 hours)
Staff: Takao Y.

  • Hello,
    We are using Green Hills Multi, under Windows 10, and using the PEMicro multilink universal FX running on a DELL Precision 7xxx laptop. All appeared to be working okay until Windows decided to 'update' itself to rev 1803. After that, Multi itself seems to still work, and compile, etc, but it cannot connect to the debugger. Downloaded and installed the latest PEMicro driver but the problem persists.

    Anybody else encounter this problem?

    Thanks in advance,

    R. G. Sheehan




    Comments

  • Greetings,

    Someone had a similar problem and the solution was to uninstall the PEDrivers from your computer and reinstall it:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=53


    Takao Yamada

  • As I said in the original post, I had already downloaded and installed the drivers.  But per your response, I went ahead and did it again.  Still cannot connect.  My copy of PROGCGZ does work, so I would think that indicates the drivers are okay.

    Green Hills mentioned a PEMicro program called 'testcfz.exe' but I can't find it anywhere on your site.

  • Greetings,

    I understand that you installed the drivers. But what I needed you to do was to UNINSTALL the drivers first, then REINSTALL it. There is a difference.

    If PROGCFZ works, then your drivers are fine.

    The problem is then the DLLs used by GreenHills needs to be updated. Read this FAQ and get the ColdFire patch:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211


    Takao Yamada

  • Sorry I did not explicitly state that I DID run the uninstall program in the C:\PEMicro\PEDrivers folder before running the just-downloaded driver installation program.

    As far as the ColdFire Patch, I DID get that patch and DID move the files to the appropriate GHS folder. Even though there was no copy of unit_cfz.dll in the Windows\System32 folder, I tried to put one there and see what happened. Still cannot connect.

  • Greetings,

    After consulting my colleagues on this issue, I found that there is one more thing that needs to be done.

    Within the P&E Cable (peserv) Connection Editor you need to modify the connection for USB to be device index of 1 instead of 0.

    See if this improves your setup.


    Takao Yamada

  • Changed device index to 1 and tried again.  Still no connection.  In the connection chooser, I set up to log to a file, and after the failure to connect, the following line was the only thing in the file:

    11:24:06.731351: SEND: DBServ1 localRN: 0x52, remoteRN: 0x51. Sending CTL_MID_SYNC

  • Greetings,

    Could you check all instances of unit_cfz.dll in your computer and replace them with the new version you found in the patch?


    Takao Yamada

  • Green Hills support had a patch that seems to correct this problem.  It looks like it had something to do with the debug server access to the license/dongle.  Thank you for your efforts.

    R. G. Sheehan

  • However, I did notice, download speeds are now not at all as quick as they once were.  My old laptop, a much slower machine, running Windows 7, downloads 2-3 times faster using the same Multilink Universal FX adapter.

  • Greetings,

    What happens if you revert the PEmicro patch and keep the patch by GreenHills? Are both patches required for you to get any connection working?


    Takao Yamada

  • Hello Takao Yamada,

    I will try to back out the PEmicro patch, although I would think someone on your end could predict whether that patch could/would slow things down. Also, Green Hills ended up getting the 'testcfz.exe' program to me and when I ran it, it appeared to download new firmware to the Multilink FX adapter. Is there any chance that program is old and predates the FX feature? If so, how can I reflash my adapter back to the appropriate factory revision?

    Thanks,

    -rgs

  • Greetings,

    Any update on this? We did not find any slow down on our end, but we do not have every ColdFire set up to test this.


    Takao Yamada

  • Hello,

    We've recently had two cases:
    New desktops,
    Windows 10 (probably 1903),
    GHS 7.x,
    Multilink Universal FX,
    Coldfire 2,3,4 port on FX.

    port number 1 is higher than total number of available ports: 0
    PEserv: possible DLL error ...

    Our current solution was to install an older version of "multilink_universal_install.exe" (maybe version 5.x)

    Are newer versions of "multilink_universal_install.exe" not installing or registering some driver file?
    Maybe the GHS 6.x or 7.x peserv.exe or unitcfz.dll files aren't compatible with the latest multilink universal drivers?

    Thanks
    Steve Warnecke
    Schweitzer Engineering Laboratories, Inc.

  • Greetings,

    More likely than not the DLL files in GHS is out of date. You can attempt to patch it up yourself using the FAQ 211:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs

    The installer does install USB Driver files. The older one may be installing older drivers that happens to work with GHS, but that can be limiting for you in the future. I am hoping the patch works so that you can continue to download the latest drivers and purchase our latest hardware.


    Takao

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement