Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
. Error during programming
Marco P. Oct 8, 2019 at 06:21 AM (06:21 hours)
Staff: Takao Y.

  • Hello,
    I am a new user of PE Multilink Universal (Rev.D).
    My goal is to use it as programmer for ST SPC560P50L5.
    Currently I am working on SPC56P-Discovery board from ST.

    This is what happen: after building on SPC5Studio IDE I have an out.hex object file.
    If I connect PE to 14way (X2) and use PROGPPCNEXUS Programmer Version 7.59.00 it is able to successfully connect and recogize the MCU.
    Then (after loading the algo: ST_SPC560P50_1x32x128k_CFlash_DFlash.pcp) attempting to program fails.

    If, before these steps, I program the MCU using the demo-board integrated programmer (from PLS) then succesive programming by PE works also.

    When programming works I can repeat it many times without problem until I decide to rebuild... after rebuild it do not work anymore.
    What can be the origin of these behaviour? Thank you for your help.


  • Greetings,

    Instead of loading the CFLASH and DFLASH combo algorithm, try just loading the CFLASH algorithm and attempt to program. Are you able to?

    Takao Yamada

  • Hi Thank you for kind reply.
    Yes I am able. I did but the result is the same.

  • Greetings,

    Are you able to erase the flash? What happens if you use the "show module" command in PROG?

    Try lowering the debug shift frequency and add 200ms reset delay before connecting. See if that improves.

    When you say programming fails, what are you seeing? Any more detail on that?

    Takao Yamada

  • Solved !

    Erasing the flash before programming solved the problem.
    Sorry I did not think about it.

    Thank you very much for excellent support!


Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement