Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Not connecting with MCUXeppress
. Sep 27, 2017 at 04:42 PM (16:42 hours)
Staff: Kevin M.

  • I'm trying to connect to a a FRDM-KL27Z board from Win10
    I've uggraded to
    Board Name is: FRDM-KL27Z
    MicroBoot Kernel Version is: 1.06
    Bootloader Version is: 1.12
    Installed Application: PEMicro FRDM-KL27Z Mass Storage/Debug App
    Application Version is: 1.18

    and the board shows up as above.
    Whatever I do whether its through "OpenSDA - USB Port" or a USB Multilink" I get
    "an error occured while connecting to the itnerface hardware or target specified "
    Any suggestions what I should be looking for, I've been trying options for two days now.
    I also run into a similar problem if I try a KDS3.2 setup.
    thanks




    Comments

    • Ok I'm connecting now. Hurrah.
      For the FRDM-KL27Z board I needed to remove the pin from J17 - this wasn't the same as the FRDM-64K board - its better set up now. Still no documentation in the UG, I had to look to the cct for a description.
      Now I can connect and download a program - but there isn't a serial port that I can find of with the PE connection. Should I be able to find one? thanks,

  • Ok - I've found the Serial over the OpenSDA - but then of course the PE interface over OpenSDA isn't connecting to the MK27Z64. 
    The PE OpenSDA not working (over win10) is what started me off trying to find a working route.
    I guess at least now I have some confidence my embedded design should work with the Multilink and need a separate debug port.

  • Yes,

    Unfortunately the process for enabling debug on these boards is not always straightforward.

    To be clear, the multilink is connecting correctly but your issue is now opensda?

    Best,

    Kevin

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement