Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
programming of KL17Z64VFM4 using PROGRACMP
vrund r. Sep 21, 2017 at 02:38 AM (02:38 hours)
Staff: Kevin M.

  • 1) Controller selection option for KL17Z64VFM4?
    2) Is .arp file required for KL17Z64VFM4?
    if yes where to get this file for KL17Z64VFM4?
    3) 3)   Which format (i.e. .hex/.s19/.srec/.out) hex file required to program KL17Z64VFM4 using PROGRACMP




    Comments

  • 1) the correct device is kl17z64m4
    2) arp file: freescale_kl17z64m4_1x32x16k_pflash.arp
    this file is in the following directory: C:\pemicro\progacmp\supportFiles_ARM\NXP\KL1x
    3) any of those formats should work, tho s19 is standard

  • Hi kevin,

    Thank you for your reply.
    I have chosen the controller : kl17z64m4.
    But while i try to connect it is not connection with the my devie(EUT).

    what are the possible cases where above situation occurs (what should i look for)?


    Thanks in advance Kevin.

    • Hi kevin,

      Thank you for your reply.
      I have chosen the controller : kl17z64m4.
      But while i try to connect it is not connection with the my devie(EUT).

      what are the possible cases where above situation occurs (what should i look for)?


      Thanks in advance Kevin.

  • Vrund,

    There are a number of reasons that the cyclone would not connect.

    1. Make sure the ribbon cable is aligned correctly

    2. Make sure your debug shift frequency is not too high. Try number 5.

    3. Make sure the target has power.

    4. Make sure that you are using the correct protocol SWD or JTAG.

    Let me know if you have any other questions

    • HI Kevin 

      I am not using cyclone.

      I am using PE micro multilink universe. rev B.

      I have taken care all the possibilities mention in your post.

      Still i am not able to connect to the EUT.

      • Adding to above information .

        1) I am using keil version 5.(under debugger PE micro option available)
        2) Now the problem is coming as Device is unsecured.
        3) I have tried all the frequency up to option 5 but still problem persists.

        Regards,
        Vrund

        • 2) Now the problem is coming as Device is secured.

          • More information.

            I have tried with last frequency option and it works.(option 27 and above it works)
            But it fails to load file.

  • Tool used: PE micro multilink universal rev b
    Controller: KL17z64

    My connection are proper.
    The ribbon cable is aligned correctly.
    debug shift frequency is not too high. (works above 25()26 to 31)
    the target has power.
    using the correct protocol SWD.

    Even after that it shows device is secured.
    it starts erasing the device.
    But after that it shows cant communicate with the device.

    Kindly suggest.

  • Is it possible that your device is permanently secured?

    That can happen to Kinetis devices.

    Have you ever connected to this device or programmed address 40C?

    Best,

    Kevin

  • Yes i am programming device with ULINK Pro using keil IDE.

  • Yes i am programming device with ULINK Pro using keil IDE.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement