Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
BKPT not active when forcing background mode at reset
Steven S. Feb 3, 2017 at 01:13 PM (13:13 hours)
Staff: Gerardo R.

  • Here is what I am seeking - what sequence of signals and states are necessary for the Multilink to apply BKPT in coordination with RESET to force background mode?

    I have a Multilink USB-ML-CFE Rev C connecting to a MCF54416CMJ250 via 26 pin BDM for programming external Flash memory.

    This setup has been used many times for programming. I have encountered a situation where a target will not enter background mode. Some boards will enter background mode, some will not. If a board enters background mode it will always enter background mode. If a board does not enter background mode it will always not enter background mode.

    To be clear, my suspicions are with the target boards and not the PE interface.

    On the boards that do not program, it appears that BKPT is not active during reset as part of the entry to background mode. BKPT is either constant high or constant low (i.e. does not pulse low relative to RESET low pulse) on successive program efforts to the same target board. Rules out a stuck-at fault on target board.

    On boards that program fine, BKPT is asserted correctly in concert with RESET.

    What signals and responses on the BDM connector are necessary to get the BKPT signal to do its task?

    Thanks in advance,
    A timely response will be greatly appreciated.




    Comments

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement