Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Error 41 when try to debug
vijay s. Jan 30, 2017 at 10:47 AM (10:47 hours)
Staff: Takao Y.

  • I am working on TRK - MPC5606B Starte TRAK Development Board , code warrior IDE version 5.9.0 and P&E debugger USM-ML-PPCNEXUS.

    I have taken the example code for SWvector from installation holder (C:\Program Files (x86)\Freescale\CW for MPC55xx and MPC56xx 2.6\(CodeWarrior_Examples)\560xB-CW\INTC-SWvector-VLE )

    Make is happening and when try to debug , getting Error 41 below is the message
    Getting the Error message Like

    Error: Error in ONCE Status register during instruction excution.
    Error: Error in ONCE Status register during instruction excution.
    Error: Error in ONCE Status register during instruction excution.
    -
    -
    -

    RAM>; Automatically generated script file for PPCNEXUS Flash Programming
    CMD>CM c:/program file(x86)\freescale\cw for mpc55xx and mpc56xx 2.6\pemicro\algorithms\000000

    Error 41 during the script
    .pcp file does not exist

    how to get the .pcp file
    Can any one help me how to resolve this issue

    Best regards
    vijay




    Comments

  • Greetings,

    Have you made any changes to Codewarrior recently that may cause this issue?

    If you have not, maybe updating will resolve the issue. Use the FAQ below to see if you can patch up your codewarrior with the latest version and see if it resolves your issue:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

    • Hi Takao Yamada

      Thank you for the information. My issue is resolved.I have updated the mentioned files.

      I have one more query : I have created my own project(for toggling a pin), but i am not able to load the software into target.Every time it loads the default program. if you have user manual of USB PowerPC Nexus Multilink USB-ML-PPCNEXUS please share.

      Best Regards
      vijay

  • Greetings,

    Even if I give you the manual for the multilink, it will not tell you why Codewarrior is programming your default project. The manual will tell you the pinouts on the 14-pin ribbon cable and typical connections to your target.

    You need to modify your project and debug configurations to make sure you are actually programming the right file. Make sure to clean and build your project and find out where the binary or ELF file is generated. Make sure it was created recently. Then confirm your connection and debug settings within Codewarrior before you start a debug session.


    Takao Yamada

  • Hi Takao Yamada

    Thank you for the information it was helpful.

    Best Regards
    vijay

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement