Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
multilink universal "can't commmunicate with target processor!"
Eileen R. Aug 28, 2015 at 03:21 PM (15:21 hours)
Staff: Takao Y.

  • Target processor is a MCF5407.  The connection manager suggests confirming power has been connected between target and cable and that is all good.  i have also tried swapping hardware to use a different 5407, changing the options in the connection manager (specifically the reset options and bdm comm speed)  and nothing is working.

    i have connected to other hardware platforms that have mcf5475, and 54418 without any trouble.




    Comments

  • Greetings,

    Have you tried lowering the debug shift frequency in the connection manager? Try the slowest speed possible. Once you can get it working, then you can start increasing the speed.

    Is this chip blank or it has been programmed before?


    Takao Yamada

  • the chip is not blank, it has been programmed before but through other means.  

    i have just tried lowering the debug shift speed to the lowest setting and also added a 5k ms delay in the reset options.

  • Greetings,

    So we know the chip is not bad and the multilink is not bad. Even lowering the debug shift frequency does not help.

    Do you know if the chip is secured? Because it is behaving like it is. On a secured chip you will not be able to enter background or communicate to it using PROG or ICD software.

    If you still have the "other means" to program it, then see if you are still able to talk using the other tool and confirm that this chip can still be talked to.

    There are ways to unsecure the chip, but understand that means erasing the chip's memory.


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement