Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Multilink Universal Rev. C not working with HCS08 in Codewarrior Classic 6.3
Daniel R. Jul 29, 2015 at 09:02 AM (09:02 hours)
Staff: Takao Y.

  • Hello,

    I'm working with Codewarrior Classic 6.3 and the HCS08DZ60 Microcontroller from Freescale. Together with Multilink Universal Rev. A (green housing) it works fine. But in Rev. C (blue housing) the debugger won't start correctly.

    See the pictures:
    http://abload.de/img/pe_1qcpg6.png
    http://abload.de/img/pe_26dral.png
    http://abload.de/img/pe_3eqpwg.png
    http://abload.de/img/pe_4fbpft.png
    http://abload.de/img/pe_5c4qih.png

    In the end it says no connection, but with Rev. A Multilink Universal this works. On the other hand Multilink Universal Rev. C works with HCS12, so the Multilink + BDM cable is OK.
    I installed the latest drivers for Multilink Universal from your website (multilink_universal_install.exe, version 5.48.0.0)

    Anyone an idea why Rev. C is not working?

    Thanks and regards,
    Daniel




    Comments

  • What I forgot: I'm using Win7-32bit

  • Greetings,

    You need to update your software with a patch. Here is an FAQ of the patch you need to download:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211


    Takao Yamada

    • Wow, it works! Thanks a lot!

      What about a direct link to the patch on the product site of Multilink Universal?
      http://www.pemicro.com/products/product_viewDetails.cfm?product_id=15320137

      There are only a lot of FAQs on left side of page and I didn't expected to find there are solution to my problem. Obviously there is a link to FAQs, but wouldn't it be better to have a direct link to the patches on right tab "Downloads"?

      Regards,
      Daniel

  • Greetings,

    It is listed in the downloads page, but the 2 columns in the downloads page are for the latest downloads and the most downloaded. But if you have searched in our forum for your problem, I have already helped over 50 people on this exact same issue.

    We do have plans to put the patches on the multilink website. The problem is it is already crowded with information and not easy to catch people's attention. It is still a corner case problem for users who are using classic Codewarrior, where most people have now moved onto the new eclipse Codewarrior.

    I am glad you were able to get things working. Do you have any other questions or concerns?


    Takao Yamada

    • Hi Takao,

      would it be possible to include the patch automatically?
      Is the folder \prog\P&E\... created by Codewarrior installer or by Multilink installer?
      In first option you could perhaps contact freescale to include this in their installer / or as a patch (I noticed there is a CW 6.3.1 patch => maybe they could create a 6.3.2 patch?)
      In second option you could perhaps recognize Codewarrior installation and automatically update it (or is that "critical")?

      Then I hope you won't need to help another 50 people :-)

      Best regards,
      Daniel

  • Greetings,

    It is created by Freescale's Codewarrior software installer. All of our software, including the multilink software, is created in your C:\pemicro\ directory. We do not have the permission to install files in Freescale's software directory. Our solution of releasing files included with a README file with simple instructions gives people comfort that they know the changes and can revert back if needed. It is not hard to do.

    Freescale has stopped supporting the classic Codewarrior. In fact, they have create multiple forum posts on their own forums and even links to our website's FAQ.

    I appreciate the suggestions. To be honest, most people have already found the answer by searching our forums and FAQ's on P&E's website and Freescale's website.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement