Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Can't flash u-boot.bin or other on MCF54455EVB
ROHOU A. Sep 24, 2017 at 11:28 AM (11:28 hours)
Staff: Takao Y.

  • Hi,

    I accidentlly erased the u-boot loader of my MCF54455EVB (Freescale).

    I just bought PROGCFZ, expecting to flash the boot-loader (u-boot.bin) with a single USB cable and standard drivers from PE.

    I converted my file .bin in .s19 using PE's converter. I control the .s19 by PE's Testcfz.
    My board has 2 flash memories (Amtel 49BV040A and Intel 28F128J3).

    I tried multiple cfg configurations, Amtel or Intel.
    I modified the cfg files (start 00000000, 04000000)
    I can't flash at 0x0400-0000 where u-boot must be installed.

    Have you any idea?

    Thanks by advance




    Comments

  • Greetings,

    Typically a custom external flash algorithm is required to program. The algorithms found in the software are default with basic configurations like using CS0 and normal address and data connections. However, yours has 2 separate flashes so there must be a custom set up used to get this working.

    You must go to our support page -> Support requests and request for a custom algorithm. You will need to provide schematics and details of how the flashes are connected.

    You can open the algorithms in a text editor to find out what kind of commands are being called to get the custom algorithm to work.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement